Skip to main content

qt & qtopia

5 replies [Last post]
djoog
Offline
Joined: 2006-12-04
Points: 0

can someone please provide us which version of qtopia & qt we need to compile with the Mr1/Mr2 code base. I have just throught the exercise of trial an error oand browsing the forum and its a bit painful.

FTR.

1) Qtopia 2.3.9 (as suggested in the forum) is not available from trolltech

2) on mr2 qtopia 4.2.2 and qt 4.2.2 which are the latest present a challenge of their own. the include file structure is different as well as major othe warnings and function signatures.

which version works/supported in mr1 and mr2 ?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
djoog
Offline
Joined: 2006-12-04
Points: 0
strim
Offline
Joined: 2006-10-20
Points: 0

Not exactly.

MR1 and MR2 have the same requirement for Qt/E 2.3.9, though close Qt/E 2.3.x versions can be suitable also.

Regarding Qt for desktop. It is needed only to build/start QVFb (Qtopia Virtual Frame Buffer) application. Please see: http://doc.trolltech.com/3.3/emb-qvfb.html. MR1 & MR2 have no dependence on Qt, but both projects have the configuration "linux_qte" that uses QVFb application as graphical output device, and as key/pointer input device.

Please pay attention that MR1 & MR2 are compatible with QVFb from Qt/E 2.3.x family only. (Thanks to Tusharj for checking 4.x). More details are in the similar thread: http://forums.java.net/jive/thread.jspa?threadID=20437&tstart=0)

djoog
Offline
Joined: 2006-12-04
Points: 0

thank you very much for the quick response !

could you the requirement for MR2 ?

tusharj9
Offline
Joined: 2005-09-22
Points: 0

hi,
You may get qt & qutopia (qt-2.3.2 and qt-2.3.10 ) from this ftp site of trolltech. MR1 should be working with them.
You will need to download and compile both to use QVFb.

ftp://ftp.trolltech.com/qt/source

Reg,
Tushar

strim
Offline
Joined: 2006-10-20
Points: 0

Thank you Tusharj, you passed ahead of me with your great link :)

I can only add that MR1 and MR2 are not compatible with Qtopia 4.x
family still. The evaluation work is planned only. If you guys have time
and desire to experiment with Qtopia 4.x I'll provide any assistance
on phoneME code. Welcome to try!

--
Yours,
Strim