Skip to main content

eclipse 3.3M2, WTP2

4 replies [Last post]
abwallis
Offline
Joined: 2006-10-23

Hi,
I'm trying to get started learning J2EE, using Eclipse. I have installed 3.3M2 with WTP2, but it seems that the glassfish plugin only works with earlier versions. Is anyone succesfully using eclipse 3.3 and WTP2 with GlassFish?
thanks

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
bakr_awad
Offline
Joined: 2007-04-20

i have followed the new eclipse 3.3 , WTP 2.0 M5
http://www.eclipse.org/webtools/jst/components/j2ee/scenarios/jee5_appli...
At step (2):-
they require server adapter plugins in WTP to work with the new facets 5.0

if any have solved this problem or managed to work around it plz replay!!!

Message was edited by: bakr_awad

ludo
Offline
Joined: 2003-06-10

Eclipse 3.3 with WTP 2.0 RC3 or above now has a new GlassFish V1, V2, V3 server adapter.
Check https://glassfishplugins.dev.java.net for more information.
Thanks,
Ludo

ludo
Offline
Joined: 2003-06-10

The plugin works only wit 3.2.x

3.3 is still under development, quite shaky (no Java EE 5 support yet, for exampe).

If you want to do Java EE 5 development and learn about it today, I would recommend NetBeans 5.5 for now, or wait for a release of Eclipse that can support Java EE 5, hopefully this year (2007).

cdiesse
Offline
Joined: 2006-09-15

The plugin also work with Eclipse 3.3 M4 and WTP 2.0M4 but it lacks java ee 5 , ebj 3.0 and servlet 2.5 versions definitions.

I am asking myself if this couldn't be resolved bu adding the correspondig facets in the plugin and ajusting libs contants and directory structures.