Skip to main content

With Tomcat

5 replies [Last post]
rmaskey
Offline
Joined: 2006-08-24
Points: 0

Using
Apache Tomcat/5.0.28
Gives me an error
java.lang.UnsupportedClassVersionError: com/sun/jmaki/JmakiController (Unsupported major.minor version 49.0)

should i be running this on tomcat at all.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
rmaskey
Offline
Joined: 2006-08-24
Points: 0

Could it be the jdk version that i am using. its 1.4.2

gmurray71
Offline
Joined: 2003-07-31
Points: 0

jMaki runs fine on Tomcat under JDK 1.5.x though we need to set the compile flags to compile to 1.4.x.

I'll file a bug on this and get this in the jMaki .5.1 release.

gmurray71
Offline
Joined: 2003-07-31
Points: 0

This issue has been fixed and will be included with jMaki .5.1

See the issue at:

https://ajax.dev.java.net/issues/show_bug.cgi?id=19

rmaskey
Offline
Joined: 2006-08-24
Points: 0

I did try it on tomcat with jdk1.5 and it did not give me any trouble. Thanks

gmurray71
Offline
Joined: 2003-07-31
Points: 0

Thank you for pointing out the problem with JDK 1.4. We want to support the widest set of users we can and I appreciate you pointing this out.