Skip to main content

EJB 3.0

1 reply [Last post]
bepplerc
Offline
Joined: 2006-08-16
Points: 0

Sorry for this newbe question, but...

There is a way to create a EJB 3.0 project using Eclipse 3.2 pointing to an GlassFish server?

I created a EJB project with GlassFish server, but it has been created with 2.1 configuration and there were no option to change to 3.0.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ludo
Offline
Joined: 2003-06-10
Points: 0

Eclipse 3.2 does *not* support EJB 3.0 or Java EE 5.

There is a plugin for JPA (Java Persistence APIs) which is a subset of EJB 3.0 under http://www.eclipse.org/dali/
This plugin does not cover the EJB 3.0 Sessions or MDB beans, and does not handle EJB 3.0 ejb-jar.xml files.

Not sure the timeframe when Eclipse will finally support Java EE 5.

Ludo