Skip to main content

problem on a debian os

1 reply [Last post]
berber
Offline
Joined: 2006-08-05
Points: 0

hi,

i've got some problem to remove lg3d-core on my debian testing.
the debian community can't help me and thez tell me to ask directly to the java community.

my problem:

#
alpha:/home/berber/Desktop/looking# dpkg -r --force-all lg3d-core dpkg - avertissement, problème contourné à cause de --force :
#
Le paquet est dans un état incohérent - vous devriez
#
le réinstaller avant d'essayer de le supprimer.
#
(Lecture de la base de données... 136257 fichiers et répertoires déjà installés.)
#
Suppression de lg3d-core ...
#
Checking if gdm is installed on the system....Yes
#
Couldn't find /etc/gdm/gdm.conf.before-LG and /etc/gdm/gdm.conf.
#
skipping moving /etc/gdm/gdm.conf.before-LG as /etc/gdm/gdm.conf
#
Error couldn't retrieve desktop file location. exiting
#
dpkg : erreur de traitement de lg3d-core (--remove) :
#
le sous-processus pre-removal script a retourné une erreur de sortie d'état 1
#
/var/lib/dpkg/info/lg3d-core.postinst: line 2: pushd: /usr/share/lg3d/ext/lg3d-x11/linux/i686/lg3d-x11/programs/Xserver: Aucun fichier ou répertoire de ce type
#
chown: ne peut accéder `Xorg': Aucun fichier ou répertoire de ce type
#
chown: ne peut accéder `Xvfb': Aucun fichier ou répertoire de ce type
#
chgrp: ne peut accéder `Xorg': Aucun fichier ou répertoire de ce type
#
chgrp: ne peut accéder `Xvfb': Aucun fichier ou répertoire de ce type
#
chmod: ne peut accéder `Xorg': Aucun fichier ou répertoire de ce type
#
chmod: ne peut accéder `Xvfb': Aucun fichier ou répertoire de ce type
#
dpkg : erreur lors du nettoyage :
#

#

#
alpha:/home/berber/Desktop/looking# aptitude reinstall lg3d-core_0.9.0_dev_i686.deb
#
Lecture des listes de paquets... Fait
#
Construction de l'arbre des dépendances... Fait
#
Lecture de l'information d'état étendu
#
Initialisation de l'état des paquets... Fait
#
Écriture de l'information d'état étendu... Fait
#
Lecture des descriptions de tâches... Fait
#
Construction de la base de données des étiquettes... Fait
#
Impossible de trouver un paquet dont le nom ou la description correspond à « lg3d-core_0.9.0_dev_i686.deb »
#
Les paquets suivants ne sont pas utilisés et vont être ENLEVÉS :
#
abiword-common bluefish cvs dia-common dia-gnome dia-libs docbook-dsssl
#
gnome-cups-manager gnome-doc-tools gnome-themes-extras gnumeric
#
gnumeric-common gpdf gstreamer0.8-audiofile gstreamer0.8-flac
#
gstreamer0.8-gnomevfs gstreamer0.8-mad gstreamer0.8-misc gstreamer0.8-oss
#
gstreamer0.8-plugin-apps gstreamer0.8-tools gstreamer0.8-vorbis
#
gtk2-engines-spherecrystal gtkhtml3.2 inkscape libboost-python1.32.0
#
libcompfaceg1 libcupsys2-gnutls10 libcurl3 libcvsservice0 libdb4.1
#
libdb4.2++ libebook8 libecal6 libedata-book1 libedata-cal5
#
libedataserver3 libegroupwise6 libexif10 libfam0c102 libflac6 libgal2.2-1
#
libgal2.2-common libgda2-3 libgda2-common libgimpprint1 libgsf-1
#
libgsf-gnome-1 libgsm1 libgstreamer-gconf0.8-0 libgstreamer-plugins0.8-0
#
libgtkhtml2-0 libgtkhtml3.2-11 libgtop2-2 libiw27 libjack0.80.0-0
#
libmyspell3 libneon23 libnetpbm10 liboggflac1 liboil0.2 libopenct1
#
libopensc1 libosp4 libpcsclite1 libpt-1.8.3 libsnmp5 libsoup2.2-7
#
libsysfs1 libwnck4 netpbm openjade planner rhythmbox synaptic
#
ttf-opensymbol xlibmesa-dri xlibmesa-glu xlibs-data xmms xserver-xfree86
#
Les paquets suivants ont été conservés :
#
console-common cron debianutils gksu guile-1.6-libs kernel-package
#
libgnomecupsui1.0-1c2a libguile-ltdl-1 libkpathsea4 libqthreads-12
#
libvcdinfo0 manpages-fr nfs-common pppconfig tasksel tasksel-data
#
ttf-bitstream-vera x11proto-fonts-dev x11proto-input-dev
#
x11proto-randr-dev x11proto-xext-dev x11proto-xinerama-dev xkb-data
#
0 paquets mis à jour, 0 nouvellement installés, 81 à enlever et 23 non mis à jour.
#
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 188Mo seront libérés.
#
Voulez-vous continuer ? [Y/n/?]

i don't understand...if you have got an idea, thank you.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
hideya
Offline
Joined: 2003-07-22
Points: 0

Hi berber,

> Couldn't find /etc/gdm/gdm.conf.before-LG and /etc/gdm/gdm.conf.
> #
> skipping moving /etc/gdm/gdm.conf.before-LG as /etc/gdm/gdm.conf
> #
> Error couldn't retrieve desktop file location. exiting
> #
> dpkg : erreur de traitement de lg3d-core (--remove) :

It looks that there is a bug in lg3d deb package in terms of uninstallation. The person who did the packaging is out until the middle of this week. It would be great if you could file a bug against it:

https://lg3d-core.dev.java.net/servlets/ProjectIssues

Thanks in advance,

hideya