Skip to main content

How does one install/use the Eclipse plugin?

9 replies [Last post]
demi123
Offline
Joined: 2006-08-04
Points: 0

I have Eclipse 3.2 and the milestone 0.3 Eclipse plugin for Glassfish. I installed it by unzipping the zip file to the eclipse directory, and it seems to have been the right place, because the plugin shows up in the Eclipse plugin list (two entries from netbeans.org). Still, I can't see the Glassfish server entries in the New server dialog. In fact, the contents didn't change at all. I have successfully used a JBoss server before with their respective plugin, in Eclipse 3.2 of course. What am I doing wrong?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
demi123
Offline
Joined: 2006-08-04
Points: 0

Tried starting with ./eclipse -clean. Nothing changed.

ludo
Offline
Joined: 2003-06-10
Points: 0

I just tried to install a clean 3.2, and then got *all* the possible extra modules, then installed the GlassFish plugin zip file.
I can register the server. So I suspect you have a wierd Eclipse installation, and the best is to start from scratch.

Welcome to plugin hell. There is little we can do on the plugins side there...

demi123
Offline
Joined: 2006-08-04
Points: 0

This is rather embarrassing, but this turned out to be a screw-up on my part. I had not installed the J2EE Standard Tools, only the Web Standard Tools -- I confused that with the whole WTP project. It all worked fine once I installed that.
Thanks for your replies, and sorry everyone! :)

ludo
Offline
Joined: 2003-06-10
Points: 0

This deploy error has nothing to do with Eclipse or its plugin. This is a GlassFish server error. See the GlassFish forums. In fact, the bug might be in the framework you use: struts or wicket which keep locks on files...

Ludo

rosnerpe
Offline
Joined: 2006-08-24
Points: 0

I have tried to install the Glassfish-Eclipse plugin as per instructions at
https://glassfishplugins.dev.java.net/download/

I have the latest version of Eclipse so I followed the instructions for Milestone 0.2.1. The zip file
glassfish-eclipse-plugin_0_3.zip did not contain
glassfish-eclipse-plugin_installer_0_2.jar
which the instructions imply. Rather it contains
com.sun.enterprise.jst.server.sunappsrv_1.0.0.jar
and some other (including NetBeans-related).

I could NOT therefore carry out the instruction
java -jar glassfish-eclipse-plugin_installer_0_2.jar

ksiow02
Offline
Joined: 2006-08-04
Points: 0

https://glassfishplugins.dev.java.net/specifications/introduction.html

I assumed you've followed the above installation guides. The only issue I'm having with the plugin is the republish error.

CLI171 Command deploy failed : Deploying application in domain failed; Could not rename C:\KAITechnologies\glassfish\domains\domain1\applications\j2ee-modules\kai-wicket to C:\KAITechnologies\glassfish\domains\domain1\applications\j2ee-modules\kai-wicket_old

demi123
Offline
Joined: 2006-08-04
Points: 0

> https://glassfishplugins.dev.java.net/specifications/i
> ntroduction.html
>
> I assumed you've followed the above installation
> guides. The only issue I'm having with the plugin is
> the republish error.

Those are not installation instructions. They are instructions one should follow AFTER the plugin has successfully been installed, but I can't do that if the Glassfish server doesn't show up in the server types list.

ludo
Offline
Joined: 2003-06-10
Points: 0

Can you try to start Eclipse with a new workspace or with the -clean option?

ilazarte
Offline
Joined: 2005-11-28
Points: 0

classic eclipse plugin deployment. i just had to peek in here with my bitter attitude, sorry.