Skip to main content

swingx demo doesn't work at all

6 replies [Last post]
smulgund
Offline
Joined: 2006-05-16
Points: 0

I can't seem to run the Swinglabs demo anymore, either on WinXP or OSX. On either platform it gives me an error. Under OSX Java Web Start tells me the following:

java.lang.Exception
at com.sun.javaws.Launcher.continueLaunch(Launcher.java:891)
at com.sun.javaws.Launcher.handleApplicationDesc(Launcher.java:515)
at com.sun.javaws.Launcher.handleLaunchFile(Launcher.java:218)
at com.sun.javaws.Launcher.run(Launcher.java:165)
at java.lang.Thread.run(Thread.java:613)

Any ideas as to what's wrong? I'd swear I used it a couple of days ago without incident. I have J2SE 5 on both machines.

Thanks

Sandeep

Message was edited by: smulgund

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
rbair
Offline
Joined: 2003-07-08
Points: 0

> I think Richard recompiled it using JDK 1.6. He'll be
> changing it back
> to JDK 1.5 as soon as possible (he's in a convention
> somewhere).

!! Sorry about that. I just recompiled everything on 1.5, double checked with 1.5 on mac and it appears to be working. Could somebody with 1.5 (and not 1.6) please give it a try and let me know if it is running?

Thanks
Richard

Antonio

It's working on my Linux box with JDK 5.0

Cheers,
Antonio

jdnc-interest@javadesktop.org wrote:

>>I think Richard recompiled it using JDK 1.6. He'll be
>>changing it back
>>to JDK 1.5 as soon as possible (he's in a convention
>>somewhere).
>>
>>
>
>!! Sorry about that. I just recompiled everything on 1.5, double checked with 1.5 on mac and it appears to be working. Could somebody with 1.5 (and not 1.6) please give it a try and let me know if it is running?
>
>Thanks
>Richard
>[Message sent by forum member 'rbair' (rbair)]
>
>http://forums.java.net/jive/thread.jspa?messageID=133620
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
>For additional commands, e-mail: jdnc-help@jdnc.dev.java.net
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

rbair
Offline
Joined: 2003-07-08
Points: 0

> It's working on my Linux box with JDK 5.0

Excellent, thanks Antonio!

Richard

Antonio

I think Richard recompiled it using JDK 1.6. He'll be changing it back
to JDK 1.5 as soon as possible (he's in a convention somewhere).

So please either use JDK1.6 or wait a little bit until he's back.

jdnc-interest@javadesktop.org wrote:

>I can't seem to run the Swinglabs demo anymore, either on WinXP or OSX. On either platform it gives me an error. Under OSX Java Web Start tells me the following:
>
>java.lang.Exception
> at com.sun.javaws.Launcher.continueLaunch(Launcher.java:891)
> at com.sun.javaws.Launcher.handleApplicationDesc(Launcher.java:515)
> at com.sun.javaws.Launcher.handleLaunchFile(Launcher.java:218)
> at com.sun.javaws.Launcher.run(Launcher.java:165)
> at java.lang.Thread.run(Thread.java:613)
>
>Any ideas as to what's wrong? I'd swear I used it a couple of days ago without incident.
>
>Thanks
>
>Sandeep
>[Message sent by forum member 'smulgund' (smulgund)]
>
>http://forums.java.net/jive/thread.jspa?messageID=132273
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
>For additional commands, e-mail: jdnc-help@jdnc.dev.java.net
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

smulgund
Offline
Joined: 2006-05-16
Points: 0

Thanks for the explanation. I do hope JDK 1.6 isn't a requirement for using SwingX!

kleopatra
Offline
Joined: 2003-06-11
Points: 0

> Thanks for the explanation. I do hope JDK 1.6 isn't
> a requirement for using SwingX!

no, swingx currently requires 1.5. I expect some lively discussions before moving to 1.6

Jeanette