Skip to main content

[VOTE] DataSet Project: Keep the name?

38 replies [Last post]
rbair
Offline
Joined: 2003-07-08
Points: 0

Before officially creating the DataSet subproject and moving the code over, I wanted to float the idea of a name change and get feedback (particularly from those who'll be committers on the new project).

Scenario:
- SwingLabs DataSet is, well, a lot like the Microsoft DataSet
- In Java SE 6 (Mustang) as part of JDBC 4.0 there will be the javax.sql.DataSet. It is totally different from both the SwingLabs DataSet and the Microsoft DataSet
- Once a name for a project is chosen on java.net, you can't change it. Ever.

So the question is: do we keep the name DataSet, or do we rename it now that we are creating a new subproject? The new name could be decided in a follow up vote, but one choice would be RelationSet, or RelationalSet.

Richard

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
david_hall
Offline
Joined: 2003-06-12
Points: 0

> > Hurry up, Richard, I'm starting to work on this
> one,
> >
> > DataButter
> > DataBummer
> > DataBatter
> > DataBatman
>
> LOL! Actually, I was hoping to hear Dave chime in one
> last time. Patrick, if you want to make the final
> call and create the Java.net project, I'll make sure
> it is part of SwingLabs. If you don't have time I can
> do it.
>
> Richard
>
> PS> Of all the options, DataBuffer is my favorite. I
> still think it should be called "Relation"-something
> :-)

You wanted more than what I posted this morning?

+1 DataBuffer

(are there list <=> forum problems again?)

dave

rbair
Offline
Joined: 2003-07-08
Points: 0

> (are there list <=> forum problems again?)

Nope, I just totally missed your and Patrick's post this morning.

david_hall
Offline
Joined: 2003-06-12
Points: 0

> Ok, my votes would be
>
> DataBuffer
> TabaLot
>
> I think we should avoid set, since we don't implement
> set operations,
> and avoid relation, as data tables are useful without
> relations (very
> useful, IMO).
>
> In the end, it's just a name, people will get used to
> it.

Of those, I vote for DataBuffer, althouhgh in either case, you're absolutely right -- it's just a name and people will get used to it. If it ends up being TabaLot, when asked where the name came from, I'll just blame^H^H^H^H^H defer the question to you. ;)

dave

Patrick Wright

Richard, why don't you just go ahead with DataBuffer?

Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

dags
Offline
Joined: 2003-06-10
Points: 0

+1 for DataBuffer

Diego.

Patrick Wright

Hurry up, Richard, I'm starting to work on this one,

DataButter
DataBummer
DataBatter
DataBatman
.
.
.

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

rbair
Offline
Joined: 2003-07-08
Points: 0

> Hurry up, Richard, I'm starting to work on this one,
>
> DataButter
> DataBummer
> DataBatter
> DataBatman

LOL! Actually, I was hoping to hear Dave chime in one last time. Patrick, if you want to make the final call and create the Java.net project, I'll make sure it is part of SwingLabs. If you don't have time I can do it.

Richard

PS> Of all the options, DataBuffer is my favorite. I still think it should be called "Relation"-something :-)

Patrick Wright

> LOL! Actually, I was hoping to hear Dave chime in one last time. Patrick, if you want to make the final call and create the Java.net project, I'll make sure it is part of SwingLabs. If you don't have time I can do it.

Err, OK, but now the fateful decision--CVS or subversion?? Ack!

People will hate me, but I'll stick with CVS for now to avoid
migration problems.

Ok, the deed is done.

Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

rbair
Offline
Joined: 2003-07-08
Points: 0

> Err, OK, but now the fateful decision--CVS or
> subversion?? Ack!
>
> People will hate me, but I'll stick with CVS for now
> to avoid
> migration problems.

Yes, SVN has many benefits, but for consistency sake with the rest of SwingLabs, CVS is a good choice.

> Ok, the deed is done.

Excellent!

Patrick Wright

> > Ok, the deed is done.
>
> Excellent!

For the record, it's awaiting approval. I'll ping the list when it's approved.

Will we be using the JDNC mailing list as well?

Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

rbair
Offline
Joined: 2003-07-08
Points: 0

> > > Ok, the deed is done.
> >
> > Excellent!
>
> For the record, it's awaiting approval. I'll ping the
> list when it's approved.

Cool.

> Will we be using the JDNC mailing list as well?

I would continue using this mailing list.

Richard

gneil
Offline
Joined: 2006-02-24
Points: 0

> > We could call it TabulrBuffr -- it'd be much more
> > Web2.0-ish that way.
> >
> -x (where x = maximum allowable) for TabulrBuffr -
> ugh!!
>

http://blog.coolz0r.com/2006/06/22/listr-20/

rturnbull
Offline
Joined: 2005-08-27
Points: 0

> TabularBuffer would be accurate, albiet fairly dry.
>
>
> We could call it TabulrBuffr -- it'd be much more
> Web2.0-ish that way.
>
> Actually -- maybe 'Tabular' (with or without the 'a')
> as a standalone name works. Maybe then we'd call the
> DataSetEL 'Totally'.

+1 for TabularBuffer, as that's what it is IMO.
-x (where x = maximum allowable) for TabulrBuffr - ugh!!

Actually, its only a project name, so you could call it ProjectX23R for all I care, as long as you have a good description.
(How about Project Richard III. DataBinding could be Project Richard II, or Richard Jnr for our American friends) :)
Or Richard III parts 1 and 2 for the English.
This is getting sillier by the minute.

Patrick Wright

Hi Ray

Sorry if I stirred up too much silliness on this thread.

One thing I've found is that I'm much more motivated to work on Flying
Saucer because it's called Flying Saucer instead of
JavaCSSXMLRenderer. The name, and Josh's great wacky logo (and
marketing :)) just make it more fun as a volunteer project. I have
enough dry analysis and specification in my daily work...having a
cute/funny name makes it a little more enjoyable.

I'm only really against using "relational" or "set" at this point, for
reasons I already gave. Otherwise, the other names seem fine to me.

Regards
Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

rturnbull
Offline
Joined: 2005-08-27
Points: 0

> Hi Ray
>
> Sorry if I stirred up too much silliness on this
> thread.
>

You can never have too much silliness

rbair
Offline
Joined: 2003-07-08
Points: 0

> > Hi Ray
> >
> > Sorry if I stirred up too much silliness on this
> > thread.
> >
>
> You can never have too much silliness

+1

rturnbull
Offline
Joined: 2005-08-27
Points: 0

> Before officially creating the DataSet subproject and
> moving the code over, I wanted to float the idea of a
> name change and get feedback (particularly from those
> who'll be committers on the new project).
>
The general consensus seems to be that the name should change.

I suggest the committers (whoever they are) select a name from the many suggested in this thread, or make up a new one if they prefer.
We are never going to get everyone to agree.

It's all very well letting everyone have their say, but sometimes someone has to make a decision, or nothing gets done.

It's time to move on, for goodness sake, or this will be another project that just fades away. :(

rbair
Offline
Joined: 2003-07-08
Points: 0

> > Before officially creating the DataSet subproject
> and
> > moving the code over, I wanted to float the idea of
> a
> > name change and get feedback (particularly from
> those
> > who'll be committers on the new project).
> >
> The general consensus seems to be that the name
> should change.
>
> I suggest the committers (whoever they are) select a
> name from the many suggested in this thread, or make
> up a new one if they prefer.
> We are never going to get everyone to agree.
>
> It's all very well letting everyone have their say,
> but sometimes someone has to make a decision, or
> nothing gets done.
>
> It's time to move on, for goodness sake, or this will
> be another project that just fades away. :(

:-D Sounds pretty dramatic! Well, I'll give my +1 for RelationSet, because it is a relational data structure (not meaning it is only useful with Relational Databases, but hey, each of the DataTables can be tied together with DataRelations!). Let's see what Patrick and Dave vote for :-)

Richard

Patrick Wright

Ok, my votes would be

DataBuffer
TabaLot

I think we should avoid set, since we don't implement set operations,
and avoid relation, as data tables are useful without relations (very
useful, IMO).

In the end, it's just a name, people will get used to it.
Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

rturnbull
Offline
Joined: 2005-08-27
Points: 0

> In the end, it's just a name, people will get used to
> it.

Right.

I wasn't trying to start another round of suggestions.
I wanted someone to pick one and move on.

Who will be in charge of this project if it ever finally gets christened?
I ask (beg) him/her/them to pick a name and set the project up.
Please!

dags
Offline
Joined: 2003-06-10
Points: 0

Just do it ! :-)

Diego.

Kleopatra

Hi Rich,

+1 for renaming.

Patrick, I love TabaLot Where's Merlin?

Jeanette

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

Patrick Wright

On 6/26/06, Kleopatra wrote:
> Hi Rich,
>
> +1 for renaming.
>
> Patrick, I love TabaLot Where's Merlin?

Already released. He's been wandering around looking for the castle
for a few years now :).

Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

rturnbull
Offline
Joined: 2005-08-27
Points: 0

Now the emphasis has switched to reviewing Swingx, what has happened to the DataSet subproject?

Has it got a name yet? If so, what is it and where can I find it?

rbair
Offline
Joined: 2003-07-08
Points: 0

> Now the emphasis has switched to reviewing Swingx,
> what has happened to the DataSet subproject?
>
> Has it got a name yet? If so, what is it and where
> can I find it?

Like most of our naming threads, this one had ended in a draw :-). It would be trivial to do the work, but no name has stuck yet. Perhaps a vote thread should be started, to force us to vote on something?

Richard

ankostis
Offline
Joined: 2005-05-23
Points: 0

Hi to all,

i find nomenclature the most fascinating aspect of programming...

How about:

Tabulin (tubulin is the protein making-up the microtubes inside every eucariotic cell, and also a candidate media for quantum computing of nerve cells)

Tabuler ?

if not, then my +1 goes to
TabuData

Kostis

s_welte
Offline
Joined: 2004-01-10
Points: 0

Just to add something new:

How about "DataTables"?

Patrick Wright

I think it shouldn't be called DataSet anymore. For one thing, anyone
familiar with .Net immediately asks if it's the same thing, and we'll
be compared to it. Likewise sql.DataSet.

I don't think it should be called Set since we don't have any
data-related set protections or restrictions (rows should comprise a
set, but they don't).

Also, I think RelationZZZ is misleading since we should concentrate on
a larger goal than just mapping to relational databases. Plus, only
the DataSet class manages relations, and until we have a binding
solution, the point is partly moot.

So I think the focus should be on the fact that we are building a
library for managing a flexible, extensible, 2-dimensional (row,
column) data structure, with in-memory persistence and various
mechanisms for loading and extracting the data. I'd suggest a name
more like "Tabular" or "Tables"...I'm sure someone else can think of a
better one :). Tabular kind of sounds kind of geeky, too :).

Regards
Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

David Bolsover

>
> So I think the focus should be on the fact that we are building a
> library for managing a flexible, extensible, 2-dimensional (row,
> column) data structure, with in-memory persistence and various
> mechanisms for loading and extracting the data. I'd suggest a name
> more like "Tabular" or "Tables"...I'm sure someone else can think of a
> better one :). Tabular kind of sounds kind of geeky, too :).
>

I know you think Tabular kind of sounds kind of geeky - but how about

Tabulate: to reduce to tables or synopses

David Bolsover
E : david@bolsover.com
T: +44(0)1614276920
M: +44(0)7773428118
F: +44(0)8700687095
W: www.bolsover.com

--
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.1.394 / Virus Database: 268.9.2/373 - Release Date: 22/06/2006

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

david_hall
Offline
Joined: 2003-06-12
Points: 0

I was going to suggest Mesa, but there's already a 3d graphics library using that name.

I agree that a rename is necessary, particularly since there will be a DataSet api in JDBC4.0.

(Data|Client|Swing)Buffer

>> Tabulate: to reduce to tables or synopses

I think we want to stick to nouns, particularly since the service we provide is primarily a generic client-side datastore.

dave

Patrick Wright

DataBuffer isn't bad. I would avoid SwingZZZ in this case as I think
(as oft repeated) that it's better to think of the library as being
Swing- (and view-) independent.

Client is also misleading, since one could use this without problems
in server situations.

I still kinda like Tabular, though.

Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

david_hall
Offline
Joined: 2003-06-12
Points: 0

TabularBuffer would be accurate, albiet fairly dry.

We could call it TabulrBuffr -- it'd be much more Web2.0-ish that way.

Actually -- maybe 'Tabular' (with or without the 'a') as a standalone name works. Maybe then we'd call the DataSetEL 'Totally'.

Message was edited by: david_hall

Patrick Wright

On 6/23/06, jdnc-interest@javadesktop.org wrote:
> TabularBuffer would be accurate, albiet fairly dry

TabuData?
TabaBuffer?
TabaLot?
Tabulong?
Tabulicious?
Tabulatory?
TabuTabu?
Tabitha?

Actually, Tabitha sounds kind of cool.

:D
Patrick

---------------------------------------------------------------------
To unsubscribe, e-mail: jdnc-unsubscribe@jdnc.dev.java.net
For additional commands, e-mail: jdnc-help@jdnc.dev.java.net

Bill Snyder

I like DataTable as well.

Patrick: TabaLot? ;) Oh boy, the first thing that came to mind...

The knights of the round table: TabaLot! TabaLot! Tabalot!
Patsy: "Its, only a [data]model..."

--Bill
[att1.html]

evickroy
Offline
Joined: 2004-07-23
Points: 0

What about [b]TabularDataSet[/b]? You still get to use the original DataSet name, but it is more descriptive of the project goal. Just a thought...

Erik

rbair
Offline
Joined: 2003-07-08
Points: 0

> What about [b]TabularDataSet[/b]? You still get to
> use the original DataSet name, but it is more
> descriptive of the project goal. Just a thought...

Not bad...

dags
Offline
Joined: 2003-06-10
Points: 0

not bad at all ...

Diego.

dags
Offline
Joined: 2003-06-10
Points: 0

I am not a committer but I vote to change the name. I would prefer RelationalSet.

Diego.