Skip to main content

[JAI-IMAGEIO] IIOException: Error 6

1 reply [Last post]
Anonymous

There are sometimes when an EOL flag is not present at the end of my
tiff image stream (source = email attachment). Usually the stream will
end in an ascii '=', but in the case where I get the below error this is
not present. Also, this doesn't happen when I am using the JAI tiff
reading method to read the stream. I guess if JAI handles it
TIFFFaxDecompressor should be able to. I can try and see if there is
some other contributing factor, but I am leaning towards a bug in
TIFFFaxDecompressor.

javax.imageio.IIOException: Error 6
at
com.sun.media.imageioimpl.plugins.tiff.TIFFFaxDecompressor.readEOL(TIFFFaxDecompressor.java:1401)
at
com.sun.media.imageioimpl.plugins.tiff.TIFFFaxDecompressor.decode2D(TIFFFaxDecompressor.java:869)
at
com.sun.media.imageioimpl.plugins.tiff.TIFFFaxDecompressor.decodeRaw(TIFFFaxDecompressor.java:676)
at
com.sun.media.imageio.plugins.tiff.TIFFDecompressor.decode(TIFFDecompressor.java:2514)
at
com.sun.media.imageioimpl.plugins.tiff.TIFFImageReader.decodeTile(TIFFImageReader.java:1132)
at
com.sun.media.imageioimpl.plugins.tiff.TIFFImageReader.read(TIFFImageReader.java:1412)
at javax.imageio.ImageReader.read(ImageReader.java:923)

Thank you,

--
Aaron Bruegl

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@jai-imageio.dev.java.net
For additional commands, e-mail: interest-help@jai-imageio.dev.java.net

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Aaron Bruegl

I am sure it's a bug in TIFFFaxDecompressor, as JAI can read the stream
fine using the "tiff" operator.

Submitted as issue #72
https://jai-imageio-core.dev.java.net/issues/show_bug.cgi?id=72

Aaron Bruegl wrote:
> There are sometimes when an EOL flag is not present at the end of my
> tiff image stream (source = email attachment). Usually the stream will
> end in an ascii '=', but in the case where I get the below error this
> is not present. Also, this doesn't happen when I am using the JAI tiff
> reading method to read the stream. I guess if JAI handles it
> TIFFFaxDecompressor should be able to. I can try and see if there is
> some other contributing factor, but I am leaning towards a bug in
> TIFFFaxDecompressor.
>
> javax.imageio.IIOException: Error 6
> at
> com.sun.media.imageioimpl.plugins.tiff.TIFFFaxDecompressor.readEOL(TIFFFaxDecompressor.java:1401)
>
> at
> com.sun.media.imageioimpl.plugins.tiff.TIFFFaxDecompressor.decode2D(TIFFFaxDecompressor.java:869)
>
> at
> com.sun.media.imageioimpl.plugins.tiff.TIFFFaxDecompressor.decodeRaw(TIFFFaxDecompressor.java:676)
>
> at
> com.sun.media.imageio.plugins.tiff.TIFFDecompressor.decode(TIFFDecompressor.java:2514)
>
> at
> com.sun.media.imageioimpl.plugins.tiff.TIFFImageReader.decodeTile(TIFFImageReader.java:1132)
>
> at
> com.sun.media.imageioimpl.plugins.tiff.TIFFImageReader.read(TIFFImageReader.java:1412)
>
> at javax.imageio.ImageReader.read(ImageReader.java:923)
>
> Thank you,
>

--
Aaron Bruegl

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@jai-imageio.dev.java.net
For additional commands, e-mail: interest-help@jai-imageio.dev.java.net