Skip to main content

.deb installation instructions

7 replies [Last post]
paulby
Offline
Joined: 2003-06-13

I've posted a very brief set of installation instructions for the .deb packages here http://wiki.java.net/bin/view/Javadesktop/Installation#UbuntuInstall

If you can test on other distros or with other graphics cards please update the wiki

Thanks

Paul

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ekerazha
Offline
Joined: 2006-03-02

Done! :)

onkarshinde
Offline
Joined: 2006-01-02

Unfortunately I can't test on my Ubuntu 5.10 (Breezy) installation since there is some problem with DRI ATI Radeon drivers.

So I will have to wait till I upgrade to Dapper on 1st June.

Please let me know if you need any other inputs.

NOTE: I recently updated java3d to 1.5 beta2 and now LG3D doesn't even start. Java 3D gives some exception about expected version of GL as 1.3 whereas it is actually 1.2 (as reported by drivers).

paulby
Offline
Joined: 2003-06-13

Java 3D 1.5 build 2 does require OpenGL 1.3 to be fully functional. Fortunately lg3d does not use the 1.3 features (multi texture) so we will be able to soften that requirement. I'll talk to the Java 3D team and find out when they will implement it.

paulby
Offline
Joined: 2003-06-13

onkarshinde, I spoke to Kevin and the fix for OpenGL 1.2 support is in the recent Java 3D 1.5 daily builds, please give it a try and let us know if you experience any problems.

Radek Kierner

Hi Paul,

Nice to here that j3d still will be support OpenGL 1.2. My OLD laptop
still will be usable to lg3d

Radek

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@lg3d.dev.java.net
For additional commands, e-mail: interest-help@lg3d.dev.java.net

ekerazha
Offline
Joined: 2006-03-02

You can improve it imho:

* sudo vi /etc/X11/xorg.conf, search for nv and change to nvidia, search for GLcore and dri module lines and comment them out

- Better:
sudo nvidia-glx-config enable
sudo gedit /etc/X11/xorg.conf, search for the dri module line and comment it out.

:-)

paulby
Offline
Joined: 2003-06-13

Thanks, go ahead and make the change in the wiki.