Skip to main content

JAI

3 replies [Last post]
manisha_128
Offline
Joined: 2006-04-23
Points: 0

Hi I'm new to JAI.Im hoping to develop a distributed Image Processing Frame Work.
I started out by installing the necessary libraries and then wanted display an image using JAI
I get this following message when i try to run it.Can anyone please help with this.

java.lang.NoClassDefFoundError: javax/media/jai/ParameterListImpl

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
amarendra_143
Offline
Joined: 2006-06-08
Points: 0

i am a beginner in JAI. i have java 1.5 installed on my machine. For JAI, i installed jai-1_1_2_01-lib-windows-i586.exe first. Then i installed jai-1_1_2_01-lib-windows-i586-jdk.exe and finally i installed jai-1_1_2_01-lib-windows-i586-jre.exe. Now when i run any program having JAI classes normally from the command prompt (javac .java and then java ), the complier gives errors of unknown symbols. Its not recognizing any of the JAI classes. I even tried updating my class path with C:\Program Files\Java\jdk1.5.0\jre\bin; but in vain. I am struck. Somebody please help me out.....

Aaron Bruegl

JAI is not on the classpath for the jre running your application. Go to
/lib/ext. Here is what it might be on Windows or Linux.

Windows:
C:\Program Files\Java\jre1.5.0_06\lib\ext

Linux:
/usr/java/jdk1.5.0_06/jre/lib/ext/

You should see at least these jars:
jai_core.jar, jai_codec.jar, mlibwrapper_jai.jar

If not, JAI has not been installed correctly - if you do see them you
are probably running your app from a different jre.

jai-interest@javadesktop.org wrote:
> Hi I'm new to JAI.Im hoping to develop a distributed Image Processing Frame Work.
> I started out by installing the necessary libraries and then wanted display an image using JAI
> I get this following message when i try to run it.Can anyone please help with this.
>
> java.lang.NoClassDefFoundError: javax/media/jai/ParameterListImpl
> [Message sent by forum member 'manisha_128' (manisha_128)]
>
> http://forums.java.net/jive/thread.jspa?messageID=106802
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: interest-unsubscribe@jai.dev.java.net
> For additional commands, e-mail: interest-help@jai.dev.java.net
>
>

--
Aaron Bruegl

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@jai.dev.java.net
For additional commands, e-mail: interest-help@jai.dev.java.net

Rafael Santos

Hello,
> Hi I'm new to JAI.Im hoping to develop a distributed Image Processing Frame Work.
>
Me too :-)
> I started out by installing the necessary libraries and then wanted display an image using JAI
> I get this following message when i try to run it.Can anyone please help with this.
>
It *seems* that JAI is not installed on the machine; is this a
client-server setup? Please give more details - how did you install the
libraries?

Rafael

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@jai.dev.java.net
For additional commands, e-mail: interest-help@jai.dev.java.net