Skip to main content

Netbeans running waaaaay slow :(

2 replies [Last post]
jess_d
Offline
Joined: 2006-03-21
Points: 0

Hi all,
I hope this is the right forum to ask this question:

I recently got back into java after a few years absence and have downloaded and started a small project on Netbeans 5.0

Initially it ran well and I really liked the interface. Then Netbeans began to bog and run really slowly. But the weird thing is occasionally is runs quickly again. But then I'll shut it down and start it up later and it will be slow again.

I'm on a relatively fast computer (T43 with ample memory) and it doesn't seem to be consuming all my memory (java.exe file has about a 140,000K memory footprint). My application is small (6 classes, simple UI). Closing the project and reopening, Shutting down the application and restarting and shutting down the entire computer and restarting all have no effect. About 1 out of 10 times I start netbeans it will run quickly. Then I put the computer to sleep or shut it down and next time it's slow.

And I'm not talking a little lag. I mean like >5 seconds from a mouse click to moving the cursor or switching between open tabs.

Has anyone else experienced this? I'm totally stumped. Thanks!

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
biwatershed
Offline
Joined: 2007-02-15
Points: 0

it may be the problem of display. I just met the same problem.
I changed the color quality to 16 bits for display, and then changed back to 32 bits. now it works well. just try to change everything of display properties. maybe it becomes better.

biwatershed
Offline
Joined: 2007-02-15
Points: 0

I just met the same problem.
I changed the color quality to 16 bits for display, and then changed back to 32 bits. now it works well.