Skip to main content

problem for ant auto-deploy-sip from Mobicent

6 replies [Last post]
barbeauxj
Offline
Joined: 2006-02-08
Points: 0

Hi all,

I have a problem, when i want to ant auto-deploy-sip like you are saying on the wikkipage for the service it doesn't work well, i have errors like:

[javac] Compiling 270 source files to C:\Documents and Settings\jba\java\prj\Mobicent1.0b2\classes
[javac] C:\Documents and Settings\jba\java\prj\Mobicent1.0b2\src\org\mobicents\slee\runtime\ActivityContext.java:54: package com.opencloud.sleetck.lib.resource.impl does not exist
[javac] import com.opencloud.sleetck.lib.resource.impl.ActivityState;
[javac] ^
[javac] C:\Documents and Settings\jba\java\prj\Mobicent1.0b2\src\org\mobicents\slee\container\SleeContainer.java:199: package com.opencloud.sleetck.lib.resource.sbbapi does not exist
[javac] import com.opencloud.sleetck.lib.resource.sbbapi.TransactionIDAccess;
[javac] ^
[javac] C:\Documents and Settings\jba\java\prj\Mobicent1.0b2\src\org\mobicents\slee\container\SleeContainer.java:326: cannot resolve symbol
[javac] symbol : class TransactionIDAccess
[javac] location: class org.mobicents.slee.container.SleeContainer
[javac] private TransactionIDAccess transactionIDAccess;
[javac] ^
[javac] C:\Documents and Settings\jba\java\prj\Mobicent1.0b2\src\org\mobicents\slee\container\SleeContainer.java:2302: cannot resolve symbol
[javac] symbol : class TransactionIDAccess
[javac] location: class org.mobicents.slee.container.SleeContainer
[javac] public TransactionIDAccess getTransactionIDAccess() {
[javac] ^

...
...

So it can't work, why ?

Thanks

Jof

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
barbeauxj
Offline
Joined: 2006-02-08
Points: 0

I've just see that in fact i ant auto-deploy-sip from mobicent from cvs but i use mobicents 1.0b2 from my computer and so the proxy is not deploy.

That's why i have the problem that i said to you before.

But how repair it ?
Because with the Mobicent from cvs I don't know how run it. I don't see run.bat

Help me please

barbeauxj
Offline
Joined: 2006-02-08
Points: 0

Hi,

Now i've just see that using the Mobicent 1-0b2 in fact the proxy is already deploy so it works well.

torosvi
Offline
Joined: 2005-07-20
Points: 0

Java doesn't get on well with blanks (C:\Documents and Settings!!!!)

Try installing your Mobicents platform in other route.

Victor

barbeauxj
Offline
Joined: 2006-02-08
Points: 0

I've just tried to change and again the same error:

[javac] Compiling 270 source files to C:\stage\java\prj\Mobicent1.0b2\classes
[javac] C:\stage\java\prj\Mobicent1.0b2\src\org\mobicents\slee\runtime\ActivityContext.java:54: package com.opencloud.sleetck.lib.resource.impl does not exist
[javac] import com.opencloud.sleetck.lib.resource.impl.ActivityState;
[javac] ^
[javac] C:\stage\java\prj\Mobicent1.0b2\src\org\mobicents\slee\container\SleeContainer.java:199: package com.opencloud.sleetck.lib.resource.sbbapi does not exist
[javac] import com.opencloud.sleetck.lib.resource.sbbapi.TransactionIDAccess;
[javac] ^
[javac] C:\stage\java\prj\Mobicent1.0b2\src\org\mobicents\slee\container\SleeContainer.java:326: cannot resolve symbol
[javac] symbol : class TransactionIDAccess
[javac] location: class org.mobicents.slee.container.SleeContainer
[javac] private TransactionIDAccess transactionIDAccess;
[javac] ^

I don't know what do!!!

Jof

barbeauxj
Offline
Joined: 2006-02-08
Points: 0

To dot it,

I use now the Mobicent from the CVS and i haven't more problem with it.

I don't know why in fact.

barbeauxj
Offline
Joined: 2006-02-08
Points: 0

I've just see that in fact i ant auto-deploy-sip from mobicent from cvs but i use mobicents 1.0b2 from my computer and so the proxy is not deploy.

That's why i have the problem that i said to you before.

But how repair it ?
Because with the Mobicent from cvs I don't know how run it. I don't see run.bat

Help me please