Skip to main content

Cannot run Browser example

6 replies [Last post]
youngjin
Offline
Joined: 2005-03-02

I cannot execute the Browser example.
I followed all the required installation steps, but it didn't work. I am using Windows XP/J2SDK1.4.2_04/Mozilla Fire Fox 1.0PR.

When I tried to run the Browser.java, I got the following exception.

java.lang.UnsupportedClassVersionError: org/jdesktop/jdic/browser/WebBrowserListener (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)

Can anyone help me solve this problem?

Thanks in advance.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
georgez
Offline
Joined: 2003-08-19

Hi burnik,

The source code of the browser example is included in all the JDIC binary/source releases (under demo/Browser directory):
https://jdic.dev.java.net/servlets/ProjectDocumentList?folderID=2495&exp...

You can check it out.

Thanks,
-George.

onclejibi
Offline
Joined: 2004-08-19

Looks like you're trying to run classes compiled with the 5.0 JDK in a 1.4.2 JRE.

Did you build it yourself? If not, try rebuilding it with a 1.4.2 JDK or download the 5.0 JRE.

georgez
Offline
Joined: 2003-08-19

Thanks, onclejibi ~. That should be the answer.

I saw the problem before with 0.8.4.*. So for new releases, I always remember to build the java code using 1.4.*, so that the binary works with both 1.4.* and 1.5.*.

yongjin,

Are you using jdic-0.8.5-bin-windows.zip? I just downloaded it and verify in my place that the Browser demo works both with 1.4.2_01 and 1.5.0-beta2-b36. So, it should work with your J2SDK1.4.2_04

Could you help to try it again, or download 1.5.0 JDK to try it out ?

Thanks,
-George.

youngjin
Offline
Joined: 2005-03-02

I have built the Browser example myself with JDK1.4.2_4, but it didn't work as I reported yesteday.
However, it works fine with the JDK5.0_RC.
What I cannot understand is that I didn't get any compilation error when I built it with JDK1.4.2_04, but I got the run-time excetpion.
Can anyone explain this problem?

Thanks in advance.

burnik
Offline
Joined: 2006-02-17

where can i get this browser example???

tnx in advance

netsql
Offline
Joined: 2004-03-07

JDIC home page has the borwser example.

I have duplicated it at www.boardVU.com (works best in IE for now).

.V