Skip to main content

Demo compile error

7 replies [Last post]
rnadler
Offline
Joined: 2007-11-15
Points: 0

Both FileExplorer and Browser demos give the following error:

bad class file: C:\projects\jdic-0.8.4-bin-windows\jdic.jar(org/jdesktop/jdic/desktop/Desktop.class)
class file has wrong version 49.0, should be 48.0
Please remove or make sure it appears in the correct subdirectory of the classpath.
if (Desktop.isEditable(selectedFile)) {
^
1 error

Please advise.
Thanks.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
georgez
Offline
Joined: 2003-08-19
Points: 0

rnadler and jthomasrose :

I checked that this problem existed with the Windows and Solaris distributions, since I built them with j2sdk 1.5.

I've rebuilt and updated the two binary distributions with 1.4.2. Now they work with both j2sdk 1.5 and 1.4.2.

Please download the updated binaries (with the same file name) and try out:
https://jdic.dev.java.net/servlets/ProjectDocumentList?folderID=1304&exp...

Thanks,
-George Zhang

rnadler
Offline
Joined: 2007-11-15
Points: 0

Thanks! The new Windows binary jar works fine with 1.4.2.

oravecz
Offline
Joined: 2003-08-11
Points: 0

The compile version problem appears to be back again. Or perhaps, the JDIC components now require JDK 1.5 to run? I am trying to use them with JDK 1.4.2_05 and get the infamous exception:

class file has wrong version 49.0, should be 48.0

kyleyuan
Offline
Joined: 2003-08-14
Points: 0

to jthomasrose: we've already fixed the browser problem. Will update the source code/binary soon.

kyleyuan
Offline
Joined: 2003-08-14
Points: 0

To madler: seems the Desktop.class is built by j2sdk 1.5 but your compiler is j2sdk 1.4.2.

Thorsten Laux

Kyle et al,

I would suggest to use a 1.4.2 compiler for the next binary distribution
to eliminate this issue.

Thorsten

jdic@javadesktop.org wrote:
> To madler: seems the Desktop.class is built by j2sdk 1.5 but your compiler is j2sdk 1.4.2.
> ---
> [Message sent by forum member 'kyleyuan' (Kyle Yuan)]
>
> http://www.javadesktop.org/forums/thread.jspa?messageID=11235&#11235
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jdic-unsubscribe@jdic.dev.java.net
> For additional commands, e-mail: jdic-help@jdic.dev.java.net
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jdic-unsubscribe@jdic.dev.java.net
For additional commands, e-mail: jdic-help@jdic.dev.java.net

jthomasrose
Offline
Joined: 2004-04-20
Points: 0

I had the same problem. I had to pull the source for JDIC and compile with 1.4.2_04 JDK. Then everything worked except for using the JDIC in a Java Web Start application. The browser would come up with the initial page, however, would not update with a new URL in the GUI, or through the API.