Skip to main content

running j3d-examples error

8 replies [Last post]
ozdemirdgn
Offline
Joined: 2004-05-12
Points: 0

i built the j3d-examples but when running i got this error:
Exception in thread "Thread-1" java.lang.UnsatisfiedLinkError: /home/xxxx/PROGS/jdk1.5.0/jre/lib/i386/libj3dcore-ogl.so: /home/xxxx/PROGS/jdk1.5.0/jre/lib/i386/libj3dcore-ogl.so: symbol glMultiDrawArraysEXT, version LIBGL not defined in file libGL.so.1 with link time reference
i have nvidia 6111 driver installed.What is the problem?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
kcr
Offline
Joined: 2004-03-17
Points: 0

What version of Java 3D? What version of Linux?

-- Kevin

ozdemirdgn
Offline
Joined: 2004-05-12
Points: 0

java3d-1_3_2-build7
red hat enterprise WS 3

kcr
Offline
Joined: 2004-03-17
Points: 0

We have seen this problem before depending on the build machine used to build the code. I don't think that's the problem this time, though. Just in case it is, could you try with the latest daily build (1.3.2-pre8-041020) and let us know whether this still breaks.

-- Kevin

ozdemirdgn
Offline
Joined: 2004-05-12
Points: 0

same error with 1.3.2-pre8-041020

kcr
Offline
Joined: 2004-03-17
Points: 0

> same error with 1.3.2-pre8-041020

If it wouldn't be too much trouble, could you try 1.3.2-build4 ? That was the build that explicitly addressed this problem and which has been known to run successfully on Red Hat with ATI cards (the system on which this bug was originally reported). Assuming that works, then it looks like the bug has been reintroduced. Otherwise, this is a new bug.

Btw, what graphics card do you have?

-- Kevin

ozdemirdgn
Offline
Joined: 2004-05-12
Points: 0

graphics card nvidia geforce2 mx 64

ok java3d-1_3_2-build4 works.thanks
i wish 1.3.2 release will be really stable.

Message was edited by: ozdemirdgn

kcr
Offline
Joined: 2004-03-17
Points: 0

> ok java3d-1_3_2-build4 works.thanks

Thanks for checking. It looks like this the same problem we had earlier. It's either a gcc bug or a linker bug.

> i wish 1.3.2 release will be really stable.

1.3.2 isn't even in Beta yet, so I wouldn't expect stability at this point. That's why the builds are labeled "experimental". The testing that you and others are doing will go a long way towards improving stability for the eventual release.

-- Kevin

kcr
Offline
Joined: 2004-03-17
Points: 0

I have a preliminary fix for this bug. Could you please test out the following build and let me know if it runs for you:

https://j3d-core.dev.java.net/servlets/ProjectDocumentList?folderID=2113...

Grab java3d-1_3_2-pre8-0410211541-linux-i586.jar from the Debug_Builds folder.

Also, if you could post the debug output that would be helpful. Thanks.

-- Kevin