Skip to main content

[JAVA2D] Tiger and Opengl

1 reply [Last post]
Anonymous

Hi,

When I try to enable the opengl pipeline, I get the following
message; "Could not enable OpenGL pipeline (GLX 1.3 not available)"

I am running linux (Gentoo) and have the latest nvidia drivers
installed (nvidia-glx and nvidia-kernel).

when I run "glxinfo | grep glx" I get:
.........
Error: couldn't find RGB GLX visual
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
client glx vendor string: NVIDIA Corporation
client glx version string: 1.3
client glx extensions:
..........

when I run "glxinfo | grep direct"
............
Error: couldn't find RGB GLX visual
direct rendering: Yes
............

I can run other opengl programs like glxgears, and it
run's fast (1600x1200) 166 frames per second.

According to the messages, GLX 1.3 is supported. I have not loaded
the DRI module,
in my xorg-x11 config file. The nvidia splash screen shows when I start KDE
and I have run "opengl-update nvidia". Is here something I missed?

Thanks in advance
Manie Coetzee

===========================================================================
To unsubscribe, send email to listserv@java.sun.com and include in the body
of the message "signoff JAVA2D-INTEREST". For general help, send email to
listserv@java.sun.com and include in the body of the message "help".

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Chris Campbell

Hi Manie,

By "latest" Nvidia drivers, do you mean 6629? What bit depth are you
running (8, 16, 32)? Which Nvidia board do you have?

I think I'd need to see the full output of glxinfo to diagnose the
problem further. If glxinfo reports errors, then it sounds like your
drivers aren't configured properly.

Chris

Manie Coetzee wrote:
> Hi,
>
> When I try to enable the opengl pipeline, I get the following
> message; "Could not enable OpenGL pipeline (GLX 1.3 not available)"
>
> I am running linux (Gentoo) and have the latest nvidia drivers
> installed (nvidia-glx and nvidia-kernel).
>
> when I run "glxinfo | grep glx" I get:
> .........
> Error: couldn't find RGB GLX visual
> server glx vendor string: NVIDIA Corporation
> server glx version string: 1.3
> server glx extensions:
> client glx vendor string: NVIDIA Corporation
> client glx version string: 1.3
> client glx extensions:
> ..........
>
> when I run "glxinfo | grep direct"
> ............
> Error: couldn't find RGB GLX visual
> direct rendering: Yes
> ............
>
> I can run other opengl programs like glxgears, and it
> run's fast (1600x1200) 166 frames per second.
>
> According to the messages, GLX 1.3 is supported. I have not loaded
> the DRI module,
> in my xorg-x11 config file. The nvidia splash screen shows when I start KDE
> and I have run "opengl-update nvidia". Is here something I missed?
>
> Thanks in advance
> Manie Coetzee
>
> ===========================================================================
> To unsubscribe, send email to listserv@java.sun.com and include in the body
> of the message "signoff JAVA2D-INTEREST". For general help, send email to
> listserv@java.sun.com and include in the body of the message "help".

===========================================================================
To unsubscribe, send email to listserv@java.sun.com and include in the body
of the message "signoff JAVA2D-INTEREST". For general help, send email to
listserv@java.sun.com and include in the body of the message "help".