Skip to main content

JAXB and Oracle Application Server 10g

1 reply [Last post]
vikasanj
Offline
Joined: 2005-11-21

I'm using JAXB from JWSDP 1.6 in a Servlet deployed in Oracle App server (10g). Whenever i use a Validator before marshalling or i set the validation property to true during unmarshalling, the servlet crashes. For eg the Servlet crashed while xecuting the following code:

Validator validator = jaxbContext.createValidator ( ) ;

The following appears in Oracles http logs:
[Sat Jun 11 18:55:22 2005] [notice] FastCGI: process manager initialized

[Sat Jun 11 19:00:07 2005] [notice] FastCGI: process manager initialized

[Sat Jun 11 19:03:34 2005] [error] [client 192.168.4.173] [ecid: 1118513014:10.3.10.204:2868:2872:1,0] (10053)An established connection
was aborted by the software in your host machine: MOD_OC4J_0087: Got an unexpected error while calling send() to send a message to oc4j
and the error code is 10053.

[Sat Jun 11 19:03:34 2005] [error] [client 192.168.4.173] [ecid: 1118513014:10.3.10.204:2868:2872:1,0] MOD_OC4J_0053: Failed to call network
routine to send out an ajp13 buffer message to oc4j.

[Sat Jun 11 19:03:34 2005] [error] [client 192.168.4.173] [ecid: 1118513014:10.3.10.204:2868:2872:1,0] MOD_OC4J_0032: Failed to send out
an ajp13 message to oc4j.

If anyone has faced this problem the please help!!

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
kohsuke
Offline
Joined: 2003-06-09

Try to get the stack trace. Otherwise it'll be very difficult to see what the problem is.