Skip to main content

WSDL file not generated ?

11 replies [Last post]
amarkel
Offline
Joined: 2004-05-13
Points: 0

I am trying to write a webservice.

I am following the instructions in this URL:

http://www.netbeans.org/kb/41/tutorial-webservice.html

I have tried deploying using both App Server 8.1, and
Glassfish.

I am unable to access the WSDL (while trying to create a
webserver client).

Inspection of the WEB-INF directory does not show a wsdl file in it.

Is the deployment supposed to generate it and create an
'actual' (with hostname and port replaced) information for
the endpoint ?

I tried the following URLs:

http://localhost:8080/web-svc/WSDL
http://localhost:8080/web-svc/wsdl
http://localhost:8080/web-svc?WSDL
http://localhost:8080/web-svc?wsdl

How can I effect the creation of a proper webservice.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
kohlert
Offline
Joined: 2003-06-16
Points: 0

The URL: http://localhost:8080/HiWS/HiWS?wsdl worked for me.
This is deploying on AS 8.1 by Netbeans itself.

judy_gao
Offline
Joined: 2005-01-25
Points: 0

Yes , I met the same problem when I play with fromwsdl sample.
I followed the instruction to try URL like:
http://localhost:8080/jax-ws-fromwsdl/addnumbers?WSDL
But I am not able to access it.
Can anybody give some suggestions on this ?

Thanks,
-Judy

kohlert
Offline
Joined: 2003-06-16
Points: 0

What version of JAX-WS are you using? Please try with the latest nightly.

amarkel
Offline
Joined: 2004-05-13
Points: 0

I am using the latest from the CVS repository (latest at the time of sending it).

I tried with the examples in the 'samples' subdirectory,
namely - fromjava -. It did not appear to package a wsdl file in the war.

kohlert
Offline
Joined: 2003-06-16
Points: 0

It doesn't package a WSDL in the war. The WSDL is generated at runtime when the service is started.

amarkel
Offline
Joined: 2004-05-13
Points: 0

I am trying - exactly - as the example pointed at.

Will report if it works.

Arieh

kohlert
Offline
Joined: 2003-06-16
Points: 0

Great, please let us know if it worked or not.

If I don't hear back from you today have a Merry Christmas and a Happy New Year!

amarkel
Offline
Joined: 2004-05-13
Points: 0

Did not work. I am unable to start the app server ...

I reinstalled NB+AS8.1.

I tried from two different systems (one of which I know
has no port conflicts), without success.

I will try to do a Tomcat deployment instead.

In any case, Happy Holidays ...

Arieh

amarkel
Offline
Joined: 2004-05-13
Points: 0

Fails to find the Wscompile ant task.

Arieh

amarkel
Offline
Joined: 2004-05-13
Points: 0

Able to start an AppServer (glassfish), deploy the HelloWS application and view its wsdl.

Finishing the year on a positive note ...

amarkel
Offline
Joined: 2004-05-13
Points: 0

My own webservice is also accessible following deployment.

Arieh