Skip to main content

Problem with commapi

4 replies [Last post]
ashlar
Offline
Joined: 2005-08-03
Points: 0

I installed the commapi following step by step the "how to" in this page ... http://www.rxtx.org/
But when i'm going to try the semple code (BlackBox) i have some error:

Error loading SolarisSerial: java.lang.UnsatisfiedLinkError: libSolarisSerialParallel: /usr/lib/libSolarisSerialParallel.so: ELF file data encoding not little-endian
Caught java.lang.UnsatisfiedLinkError: readRegistrySerial while loading driver com.sun.comm.SolarisDriver
Error loading SolarisSerial: java.lang.UnsatisfiedLinkError: libSolarisSerialParallel: /usr/lib/libSolarisSerialParallel.so: ELF file data encoding not little-endian
Caught java.lang.UnsatisfiedLinkError: readRegistrySerial while loading driver com.sun.comm.SolarisDriver
No serial ports found!

Could someone help me?
Thx
p.s. sorry for my english

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
cocktail1
Offline
Joined: 2010-10-19
Points: 0

Thanks very much for the comment and the info.I'm very interested in this space and consult to clients in pieces of it.
Thank you and everyone that commenting on providing great traffic tips.

_________________
[url=http://www.carinadresses.com/formal-dresses/cocktail-dresses.html] cocktail dresses [/url]

dukster
Offline
Joined: 2005-07-28
Points: 0

Your getting unsatisfied link errors because you haven't set your LD_LIBRARY_PATH - set this to the location of your .so libs.

ashlar
Offline
Joined: 2005-08-03
Points: 0

i put this library in my path:
export LD_LIBRARY_PATH=/usr/bin/libSolarisSerialParallel.so
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/java/j2sdk1.4.2_06/jre/lib/i386/librxtxParallel.so
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/java/j2sdk1.4.2_06/jre/lib/i386/librxtxSerial.so

but the error is the same... i tryed everything and i don't have idea how to resolve my problem :(

podlesh
Offline
Joined: 2004-07-26
Points: 0

LD_LIBRARY_PATH contains directories where libraries are.

In your case:
export LD_LIBRARY_PATH=/usr/bin:/usr/java/j2sdk1.4.2_06/jre/lib/i386