Skip to main content

Jaxws2.0 and WSDL 2.0

1 reply [Last post]
janilsal
Offline
Joined: 2003-06-10

I searched this forum before I am asking. Found no discussions. If it has already been answered, my apologies.

I would like to know if there are any options in tools to generate wsdl 2.0 instead of wsdl 1.1?

I know that WSDL 2.0 is not yet ratified by w3c. But doesn't jaxws 2.0 require wsdl 2.0?

Appreciate an answer from the Sun developers.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
kohlert
Offline
Joined: 2003-06-16

Since WSDL 2.0 has not been ratified by w3c and schedule constriants placed on JAX-WS by other specs, WSDL 2.0 is no longer required by JAX-WS. WSDL 2.0 will undoubtedly be supported in maintenance releases of JAX-WS.