Skip to main content

Running JDK 1.1.7 code in JDK 1.4.2?

3 replies [Last post]
innes
Offline
Joined: 2005-07-01
Points: 0

Hi,

I am new to Java & have inherited a system which runs JDK 1.1.7. This needs to be updated to JDK 1.4.2. Therefore my question is -
Will I be able to compile the 1.1.7 code in 1.4.2 & is it likely to run? Any help is much appreciated.

David.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
peter_lawrey
Offline
Joined: 2005-02-24
Points: 0

The same question has been posted to other forums.
He appears to be looking for assurance which is not forth coming or someone to hold his hand when he tried it??

jwenting
Offline
Joined: 2003-12-02
Points: 0

Maybe, my attitude when I'm in such a situation is more like "what the heck, at worst we have to revert to a backup" and just try :)

jwenting
Offline
Joined: 2003-12-02
Points: 0

OK, you post a question about using 1.1 code in a 1.4 JVM on a forum dedicated to a future 1.6 version of the language.
Please enlighten me about the relevance of your question to the topic of the forum.