Skip to main content

Using JAXB2.0 with JDK1.4.1

3 replies [Last post]
srinivasrao
Offline
Joined: 2004-10-06
Points: 0

Hi,
As the JAXB requirements say JAXB2.0 require JSDK1.5.
Just to check with the forum, can we use jaxb2.0 with JDK1.4.1.
Did any one tried to using jaxb2.0 with JDK1.4.1.

As our corporate direction is to use JDK1.4.1, we have no choice to use JAXB1.0, but we are inclined to use JAXB2.0 because of the features available.
Any sugestion on this.

Regards,
Srinivas.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
pelegri
Offline
Joined: 2003-06-06
Points: 0

J2SE 5 was really a big change in the language. It is hard to kind-of use J2SE 5: you either do, or you don't. There are a number of specs that are relying on it, and JAXB 2.0 is one of them.

Luckily the support curve for J2SE 5 is faster than some earlier releases, and we expect substantial support by the time JAXB 2.0 goes final. I'm a MacOS-X user and Apple just released J2SE 5 for MacOS 10.4.

- eduard/o

kohsuke
Offline
Joined: 2003-06-09
Points: 0

If you look at the spec or any of the tutorials/blogs/samples, I think it's pretty obvious that it really uses JDK 1.5 features.

But if you have any technical suggestions as to how to potentially modify the JAXB RI to work with JDK 1.4, I'm more than happy to listen.

I had thought about this some time ago, but at that point I felt that it's really not practical.

kirillcool
Offline
Joined: 2004-11-17
Points: 0

Hate to say the obvious, but if the requirements are for 1.5, how do you expect running with 1.4.1? You can try it with 1.4.1, the only problem is - it will not compile (because of the annotations. and the generics. and...)