Skip to main content

JAXB 2.0 prerequisites

2 replies [Last post]
kirillcool
Offline
Joined: 2004-11-17
Points: 0

As i understand, JAXB 2.0 is planned to be a part of J2EE5.0 and J2SE6.0, as well as a standalone distribution.

Two requests:
1. Make only J2SE 5.0 prerequisite for JAXB 2.0. Requiring Mustang features will seriously undermine JAXB 2.0 exposure.
2. Modularize WebService Pack installer - selecting a single package (say, JAXB, JAXP or SAAJ) will install only the needed parts. The current state - take everything in jaxb/lib and shared/lib is an overkill.

Kirill

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
kohsuke
Offline
Joined: 2003-06-09
Points: 0

As Eduardo mentioned, JAXB 2.0 will only require J2SE5.0, not 6.0.

But your post made me think about if there's any feature in Mustang the RI can take advantage of.

pelegri
Offline
Joined: 2003-06-06
Points: 0

The first one is an easy one: JAXB 2.0 will be part of J2EE 5. Since J2EE 5 requires only Tiger, there can be no dependency on Mustang in the JAXB 2.0 spec (unless one were to make that dependency optional, but optionals complicate the life of the spec writer, so I very much doubt that would happen).

The second is feedback for the JWSDP team, and probably best set to the USERS mailing list of the jwsdp project (http://jwsdp.dev.java.net).

Thanks,
- eduard/o