Skip to main content

Can't run the 6.0 jar file using jre 1.3

2 replies [Last post]
somejeff
Offline
Joined: 2004-11-16

Ironically, the jre that I have on my x86 is 1.3.1_02.
I download the 6.0 source jar to take a peek and cannot run the Installer class within the jar file.

java.lang.UnsupportedClassVersionError ... (Unsupported major.minor version 49.0)

I had to upgrade my jre to in order to execute the 6 src.

Perhaps a note should be added to the download web page to mention what version of the jre is needed to get the src to 6.

Or, just zip up your java files and post it, why have an installer and extractor just to get source?

JL

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
wingetr
Offline
Joined: 2004-01-19

It requires an installer to make sure we accept the license before extracting.

bino_george
Offline
Joined: 2003-06-16

Hi,

> Perhaps a note should be added to the download web
> page to mention what version of the jre is needed to
> get the src to 6.
>

Good catch. Will do.

Regards,
Bino.