Skip to main content

What recent version of Java do you want third-party frameworks to support?

Must be J2SE 1.4 compatible
22% (162 votes)
Prefer J2SE 1.4 compatible
9% (66 votes)
No preference
3% (21 votes)
Prefer use of J2SE 5 features
40% (297 votes)
Must use J2SE 5 features
25% (190 votes)
Something else (please comment)
2% (12 votes)
Total votes: 748

Comments

Poll results do not add up to 100%

Hi There, Looks like the following poll reults do not add up to 100%. Must be J2SE 1.4 compatible 21.8% (100 Votes) Prefer J2SE 1.4 compatible 10% (46 Votes) No preference 2.8% (13 Votes) Prefer use of J2SE 5 features 41.5% (190 Votes) Must use J2SE 5 features 22.3% (102 Votes) Something else (please comment) 1.3% (6 Votes) Regards, Pramod

Poll results do not add up to 100%

Those percentages add up to 99.7%. It is likely the "missing" 0.3% is a result of rounding/truncating.

jse 1.6

WebSphere sucks!

Instead of giving us Tiger one year too late IBM are focusing their efforts on "useful" stuff like "WebSphere ESB". I am so sure! Thanks a lot, IBM! (Not!)

JSE 1.2!

The lower the target platform a framework targets, the larger the installed base that can use it. Java's backward compatibility has been pretty good, (except for class file formats) unfortunately, its forward compatibility has been shockingly abysmal. Generally speaking; a library works on the platform version it targets, and all later versions of the Java runtime, but none of the earlier releases.

Different for desktop

For serverside Frameworks 1.5 is good (especially as the new concurrency stuff is useful) - for desktop frameworks still can't use anything beyond 1.4 until 1.5 is available by default on Macs