Skip to main content

Max Memory Size Phoneme Advanced linux-x86-generic

Please note these forums are being decommissioned and use the new and improved forums at
3 replies [Last post]
Joined: 2011-07-11


How can I increase the memory size above 1024*1024 (1mb)?

I tried Xopt but the max value is 1048576

I used the following ./cvm -Xopt:stackMaxSize=1048576 -Xmx4m -Xms4m -Xmn4m ...

but it seems to have no effect. I think I need to change stackMaxSize in the VM before compiling.

I was thinking of changing it in global.c but I don't know if this will work:

{"stackMaxSize", "Java stack maximum size",
{{1024, 1 * 1024 * 1024, 128 * 1024}},

I don't think that the vm will be able to access higher than 1*1024*1024 (I was thinking of changeing to 1*1024*4096)

Please advise.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2006-10-16

I assume by "memory" you are referring to the native statck size, since you have tried -Xopt:stackMaxSize. That will only affect threads created by the VM. The main java application runs in the main linux application thread, and therefore its size is controlled by the "limit" command.

Joined: 2011-07-11

I am getting an out of memory error from the VM

When I run ulimit -a before running the application I get:

core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 20
file size (blocks, -f) unlimited
pending signals (-i) 16382
max locked memory (kbytes, -l) 64
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) unlimited
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited

So the problem appears to be with the VM (I am testing google maps on a linux PC) How can I increase the VM memory size to prevent an Out of Memory error?

Joined: 2011-07-11

The problem is with the build for the Linux PC using qt

The build for the linux-arm-generic with gtk1.2 works fine on my Nokia 770 OS2006

Google maps works on the Nokia with no errors - I'll post the steps to the build and how to run google maps on the Nokia 770 OS2006 on wordpress - nokia770hacker for others to install google maps and other midlets on the Nokia 770 OS2006 using PhoneME and Midpath

Thanks for your help - I'm satisfied with what I have now