Skip to main content

Can't Install Tru2way Workbench in Eclipse on Windows

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
8 replies [Last post]
alex_brown
Offline
Joined: 2010-05-25
Points: 0

Running Windows 7, Eclipse Helios 3.6.2 and 3.6.1 for Java Developers
Unable to install the plugin from
http://ri.opencable.com/sdk/updates/eclipse.3.6/stable/latest/
http://ri.opencable.com/sdk/updates/eclipse.3.6/stable/Rel5/
http://ri.opencable.com/sdk/updates/eclipse.3.6/head/
Nor can I install from the "TWB Installer"
I get the following error in eclipse when beginning the install:
<strong>Cannot complete the install because some dependencies are not satisfiable - org.tru2way.twb.feature.feature.group [1.0.0.201103102226NGT] cannot be installed in this environment because its filter is not applicable.</strong>
Any insight would be appreciated. I have tried rolling back my version of eclipse, clearing all eclipse meta data (that I could find), new workspaces, etc.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
csweeney
Offline
Joined: 2009-04-11
Points: 0

Starting with a clean install of "Eclipse IDE for Java Developers" (http://www.eclipse.org/downloads/download.php?file=/technology/epp/downl...) I was able to install TWB from the "head" update site (http://ri.opencable.com/sdk/updates/eclipse.3.6/head/).
I'm investigating based on user's Eclipse installation details...

csweeney
Offline
Joined: 2009-04-11
Points: 0

I'll try and replicate. You might check the error log (Window->Show View->Error Log) for any additional information.

csweeney
Offline
Joined: 2009-04-11
Points: 0

Starting from "Eclipse SDK" (http://download.eclipse.org/eclipse/downloads/drops/R-3.6.2-201102101200...) I am able to replicate the error. The detailed error message I get is:
<pre>
Cannot complete the install because one or more required items could not be found.
Software currently installed: tru2way Workbench Feature 1.0.0.201104082136NGT (org.tru2way.twb.feature.feature.group 1.0.0.201104082136NGT)
Missing requirement: Platform UI Plug-in 1.1.0.201104082136NGT (org.tvt.platform.ui 1.1.0.201104082136NGT) requires 'bundle org.eclipse.wst.validation 0.0.0' but it could not be found
Cannot satisfy dependency:
From: tru2way Workbench Feature 1.0.0.201104082136NGT (org.tru2way.twb.feature.feature.group 1.0.0.201104082136NGT)
To: org.tvt.platform.ui 1.1.0
</pre>

alex_brown
Offline
Joined: 2010-05-25
Points: 0

My error log shows as follows:

!SESSION 2011-04-13 14:29:02.152 -----------------------------------------------
eclipse.buildId=M20110210-1200
java.version=1.6.0_23
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.java.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.java.product

!ENTRY org.eclipse.equinox.p2.operations 4 0 2011-04-13 14:36:18.743
!MESSAGE Operation details
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-04-13 14:36:18.743
!MESSAGE Cannot complete the install because some dependencies are not satisfiable
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-04-13 14:36:18.743
!MESSAGE org.tru2way.twb.feature.feature.group [1.0.0.201012231715NGT] cannot be installed in this environment because its filter is not applicable.

!ENTRY org.eclipse.equinox.p2.operations 4 0 2011-04-13 14:36:18.759
!MESSAGE Operation details
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-04-13 14:36:18.759
!MESSAGE Cannot complete the install because some dependencies are not satisfiable
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2011-04-13 14:36:18.759
!MESSAGE org.tru2way.twb.feature.feature.group [1.0.0.201012231715NGT] cannot be installed in this environment because its filter is not applicable.
csweeney
Offline
Joined: 2009-04-11
Points: 0

By adding "Eclipse Web Developer Tools" I was able to install TWB, create a "Hello World" project and run/launch it.

alex_brown
Offline
Joined: 2010-05-25
Points: 0

I tried this step but it was not successful. However, I'm inclined to agree that this issue is due to a missing dependency or dependencies.
I have emailed you a list of how my Eclipse is configured. I looked through the SDK Rel 5 Release Notes and see no specific list of dependencies. That document appears to rely on the "Eclipse IDE for Java Developers" having all the requirements tied in. However, that doesn't appear to be the case if other items need to be installed before the TWB can be installed.
I also didn't find any way from error logs in Eclipse to point me towards downloading any specific plugin or set of tools. How did you conclude that the Eclipse Web Developer Tools were necessary to correct your environment?

alex_brown
Offline
Joined: 2010-05-25
Points: 0

For the record, these are the steps I've taken:
I started with the SDK release notes install guide:

  1. I downloaded 'Eclipse IDE for Java Developers" as per section 1.5.1 step 1.
  2. I then started Eclipse, launching to the workbench. On startup I chose a brand new workspace.
  3. Help -> Install New Software and used http://ri.opencable.com/sdk/updates/eclipse.3.6/stable/latest/ which discovered Build:tags_Rel5-13310
  4. Checked that, clicked Next
  5. Waited for about a minute as the progress bar climbed and received the fatal error. The status of the install was "Calculating requirements and Dependencies" at the time (as expected)

Next, I installed "Eclipse Web Developer Tools" as per your suggestion

  1. Back to Help -> Install New Software. Set "Work with" to Helios - http://download.eclipse.org/releases/helios which was already available in the dropdown
  2. Expanded "Web, XML and Java EE Development"
  3. Put a check beside "Eclipse Web Developer Tools"
  4. Click Next, Next, Accepted license agreement, Finish
  5. The install of the Web Dev Tools proceeded
  6. Eclipse requested a restart, so I did that

Upon restart, I proceeded back to step 1 where the install of the RI SDK failed again.
I'm going to leave this install alone and try with the link you used (download.eclipse.org/eclipse/downloads/drops/R-3.6.2-201102101200/download.php) and see if I have more success with that.

alex_brown
Offline
Joined: 2010-05-25
Points: 0

I tried the eclipse you initially installed with at download.eclipse.org/eclipse/downloads/drops/R-3.6.2-201102101200/download.php and hit the same problem you described in, as it was missing bundle org.eclipse.wst.validation 0.0.0
However, this is not the same problem I was experiencing: the error appeared after you started the installation, a point I could never get to. The error I saw happened during the initial validation of the TWB plugin itself. For example, I never got to accept the terms of the license agreement of the TWB at all. I recieved an error before that point.
So while I do have an install of Eclipse with TWB successfully installed, I still have my initial issue with the eclipse the release notes tells me to use. The good news about all this is that I can compare the working to the non-working and so I compared the two installs of Eclipse. The working Eclipse included the following features that the non working did not:
org.eclipse.sdk (3.6.2.r362_v20100929-7Q7m7HD5cWlFgdCBHllpZMd2M468sbnm2RJvUWIbiJnWC) "Eclipse Project SDK" and
org.eclipse.pde (3.6.2.r362_v20110203-7b7mFL2FET3dhHalh1iNZtL) "PDE"

I installed both of these but unfortunatly that didn't solve the problem. The only other notable difference is that Mylyn is installed on the non-working Eclipse.