Skip to main content

Tipster theme bug with keyboard

8 replies [Last post]
nogema
Offline
Joined: 2011-11-24
Points: 0

Hi !

I used the tipster base theme to make mine.

I actually have some TextField on a Form. On Resource Editor, if I click on one of them, keyboard appears (OK). If I click on ".,123" button, I'm unable to validate text or delete ... (buttons disappears !)

The problem is the same on device !

You can test this on Resource Editor using Tipster theme. It seems to be there is only a problem using this theme.

Actually what do I need to change in Resource Editor to skip this problem ?

Thanks !

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
vprise
Offline
Joined: 2003-11-07
Points: 0

Thanks for the notice, its indeed a bug in LWUIT and I will commit a fix for it shortly!

The crux of the issue is the style assigned to the TitleArea which is causing an issue with dialog size calculations.

nogema
Offline
Joined: 2011-11-24
Points: 0

Ok thanks !

Can you say me in this thread when svn is up to date fixing this bug ?

vprise
Offline
Joined: 2003-11-07
Points: 0

I committed it that same day. I think 20 minutes or so after my post.

nogema
Offline
Joined: 2011-11-24
Points: 0

Thanks !

I recompiled library from SVN trunk folder.

It seems to be better but I always have some problem on emulator (I will check next week on real device).

Buttons are present but some difficult to access them and strange things on the upper !

vprise
Offline
Joined: 2003-11-07
Points: 0

That's odd, I saw this exact behavior before the fix and now it no longer occurs. Is it possible you are still linking to the binary library in the final project (keep in mind that the code that actually uses LWUIT might be in a sub project if you use the new project structure).

nogema
Offline
Joined: 2011-11-24
Points: 0

Ok, I test again and ... it's not working with MY own theme (tipster theme is ok).

I just change few things compare to the original tipster theme.

I uploaded my res file (just the theme and one screen for test) if you can look as soon as possible at this problem :

http://www.megaupload.com/?d=YPF0647T

Thanks :)

vprise
Offline
Joined: 2003-11-07
Points: 0

You need to define hideEmptyTitleBool to true in your theme constants to hide the title of the VKB dialog completely.

Please file an issue for things like this in the future since you can attach files to issues without the whole downloading from sites like that. Thanks.

nogema
Offline
Joined: 2011-11-24
Points: 0

Thanks a lot ! it's now working properly :)

I'll check to fill an issue the next time I encouter a lwuit bug !