Skip to main content

Facebook Implementation in LWUIT

8 replies [Last post]
sriramjava86
Offline
Joined: 2010-06-15
Points: 0

Hi,

Iam trying to run the FacebookDemo app given by the LWUIT_1_5. While Build the application iam getting the following error

output shows - Error preverifying class generated.StateMachineBase java/lang/NoClassDefFoundError:com/sun/lwuit/util/UIBuilder and it also says Preverification failed with error code:1

The following are the list of Jar's i added as mentioned

IO.jar, UI.jar , LWUIT_MIDP.jar(1.5 version) and MIDP_IO.jar

Iam expecting that this error will come when LWUIT Jar file correcpted. But added latest LWUIT_1_5 jar file.In that jar i found UIBuilder class also. I stucked here, Need help ASAP.

Thanks,

Sriram.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
vprise
Offline
Joined: 2003-11-07
Points: 0

You don't need to include UI.jar since UI_MIDP.jar includes it.

Make sure you updated project paths and simulators both in the parent project and within the child projects.

SuyashSingh
Offline
Joined: 2011-11-04
Points: 0

I am checking facebook implementation Demo app in lwuit. After login to facebook it reditects me to Allow and Don'tAllow page. After pressing Allow it is again sending me login page and this is happening every time, when i m pressing DontAllow it again redirect me to login page.In that Allow and Don't Allow page if i am selecting my AppName which is showing on top,I am able to enter the facebook but in that page which one is Selected i am unable to find out.Please help me and give me some suggestion as soon as possible.

Thanks & Regards

skranjanin
Offline
Joined: 2011-11-27
Points: 0

I am facing the same problem. The moment I click on "Allow" button of the Facebook Permission page, I am redirected to the login page. I have crossed checked by following the same steps on the web browser and it for some reason the "refsrc" of the url instead of pointing to the our app domain, is pointing to m.facebook.com and hence the oAuth code is not generated at all. Has anyone been able to resolve it?

Thanks & Regards

Ranjan

chenf
Offline
Joined: 2008-04-29
Points: 0

Hi,

Which device, emulator are you using?

The facebook API depends on auth2 which from our experience works on latest nokia's and the latest SDK 3.0.5 -

http://www.oracle.com/technetwork/java/javame/javamobile/download/sdk/index.html

Regards,

Chen

skranjanin
Offline
Joined: 2011-11-27
Points: 0

Thanks for the response Chen. I've been trying the LWUIT Browser on the actual devices rather than on the emulators. The devices I've tested are Nokia X3-02, a S40 6th edition device, and Nokia 5800 XpressMusic, a Symbian S60 device, and on both of these, clicking on the "Accept" button takes me back to the login page. I believe it might either be a problem with the cookies that is being passed but not entirely sure.

Thanks

Ranjan

skranjanin
Offline
Joined: 2011-11-27
Points: 0

Just to update on the issue. Tested on the 3.0.5 emulator and it does work fine, but unfortunately even on newer devices such as the X3-02, it doesn't.

SuyashSingh
Offline
Joined: 2011-11-04
Points: 0

Hi Ranjan,

Have you find any solutions of our problem. After pressing Allow and Don't Allow page it navigates to login page. If u get any solution please help me. I have tested my app to E5 but it is not working.I have checked it for SDK 3.0.5 it is working fine on emulator.Please reply asap.

Thanks

Suyash

vprise
Offline
Joined: 2003-11-07
Points: 0

Its possible that the operator removed the certificate from the device or the specific firmware lacks it. We worked with older Nokia devices which did support it.

Unfortunately there isn't much we can do to resolve that.