Skip to main content

Error starting module attempts to access a secure API

4 replies [Last post]
Leleo
Offline
Joined: 2011-11-19
Points: 0

How to solve this problem: Error starting/module attempts to access a secure API. I'm using a Blackberry.

Thank's in advance.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
vprise
Offline
Joined: 2003-11-07
Points: 0

You need to use the unsigned version of the blackberry port unless you intend to sign your application.

Leleo
Offline
Joined: 2011-11-19
Points: 0

Hi vprise . I changed the archive .jar LWUIT_Blackberry_4_7_OrNewerSigned for LWUIT_Blackberry_4_7_OrNewer and I had success.

What is the difference between files and LWUIT_Blackberry_4_7_OrNewerSigned LWUIT_Blackberry_4_7_OrNewer?
Thank you

vprise
Offline
Joined: 2003-11-07
Points: 0

Some features such as access to device properties, browser (excute method) and something else require signing. Really annoying since even if you don't invoke these API's physically RIM fails running. No wonder we hate RIM with a vengence.

Leleo
Offline
Joined: 2011-11-19
Points: 0

I understood. Tnk's