Skip to main content

Empty statemachine base???

1 reply [Last post]
tdgs
Offline
Joined: 2011-03-31
Points: 0

hello I recently started using Resource editor and I have a question:I 'm trying to create a simple project just for test purposes in Resource Editor:nothing special just a Label with a hello world, but when I push "create Netbeans project" while all the projects(JavaSE,MIDP ,RIM) are created none of them are running. In normal JaVA I just get a black screen and in MIDP emulator I get a message saying "This application runs in the background".
My StateMachineBase code is this
public class StateMachineBase {
public StateMachineBase(String s) {}
}

And My StateMachine code is this:
public StateMachine(String resFile) {
super(resFile);
// do not modify, write code in initVars and initialize class members there,
// the constructor might be invoked too late due to race conditions that might occur
}

/**
* this method should be used to initialize variables instead of
* the constructor/class scope to avoid race conditions
*/
protected void initVars() {
}

So I'm guessing my prgramm obviously won't do anything since there is no code. What am I doing wrong? From my understanding StateMachineBase should have all the boiler code.I'm using Netbeans 6.9.1 ,Lwuit latest version and JavaME SDK 3.0 and Nokia S60 SDK.
Thank you.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
vprise
Offline
Joined: 2003-11-07
Points: 0

That's a bug in the current version. The workaround is to simply save the resource file in the resource editor which immediately regenerates the base class.
I will update it in my next commit.