Skip to main content

Blackberry Torch Support

3 replies [Last post]
hectorharvey
Offline
Joined: 2009-10-22
Points: 0

I have a Blackberry application that I need to enable for the Torch device. My previous build was before the major refactoring of SVN. I was able to build and deploy with the 1.5 binary jar. It works correctly on the simulator but on the actual device will not accept input from the keyboard. I can navigate around and select a check box as the track ball/pad works correctly. I have a diagnositc field that reports the key code, and the key code is correctly reported. But no typed characters show in the field.

1) Any suggestions on how to correct this?

The solution may be moot as what I really need is Torch support, and the 1.5 binary does not accept a screen tap on a button.

2) Is there a 1.6 binary I could use? If not please consider a monthly 1.6-alpha/beta build. I think it could benefit many.

I am afraid that building the binary myself would be a suck hole of time to figure out. Looks like there are 3 or more properties files I would have to create/populate. If anyone could post some samples of those that would be helpful.

Thanks for any help.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
hectorharvey
Offline
Joined: 2009-10-22
Points: 0

As it turns out the emulator was tricking me with an older version of my application, and when I got the correct code loading into the emulator, it failed the same way the device failed.

The TextField input was failing because of a setConstraint(NON_PREDICTIVE). Removing this constraint allowed the field to receive the typed characters correctly... though now it capitalizes the first character which is not desired for my application.

vprise
Offline
Joined: 2003-11-07
Points: 0

Please file an issue on that, we need to fix all input modes for the BB devices.

We were having some issues with the BB port due to lack of device, I am just in the process of procuring a new device for us so hopefully the port will improve in the coming months.

vprise
Offline
Joined: 2003-11-07
Points: 0

Notice that there are 3 binaries for 1.5. You need to use either the newOS or newOSSigned binary.