Skip to main content

Blackberry builds but then has verification error on emulator

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
1 reply [Last post]
68060
Offline
Joined: 2011-08-29
Points: 0

Any idea how to fix this? Obfuscation is off, I got one .cod to run on the 9500 emulator, then I tried the non touch one in the 8800 emulator and it was complaining about verification errors, help would be greatly appreciated,

Screenshot here from emu: http://dl.dropbox.com/u/4194619/verificationerror.png

EDIT: OK not really a solution considering its supposed to work on OS 4.2 but I tried the emulator (8800) with OS 4.5 and it worked, no verification errors, that will have to do for now! If anyone knows why it wont work on 4.2 but works on higher ones Id love to know..!

Gareth

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
vprise
Offline
Joined: 2003-11-07
Points: 0

Is the application signed?

When you get the verification error use the ALT-LGLG key combination to go to the device log and look for the reason of the crash. These are often very indicative of what went wrong and might assist us in nailing the problem.