Skip to main content

Running JXTA Shell with local Rendezvous

1 reply [Last post]
altmann
Offline
Joined: 2011-02-16
Points: 0

Hi Community,
I'm trying to get JXTA running. I tried several tutorials using the JXTA Shell. In the tutorials seting Rdv and Relay URLs to a public node were proposed. But the proposed cgi-Scripts and the sites weren't available.
Thus, I went over to get launching my own Rdv+Relay-Node. The first idea was to test and get it running in my local WLan, before migrating the code to my public server.
I found an example code here: radioae6rt.wordpress.com/2006/11/15/a-turnkey-private-jxta-net-demo/ from here: http://wiki.java.net/bin/view/Jxta/LinuxRendezvousRelayDaemon.
I set the seed.txt to my local WLan IP and configured the build.properties with JXTA_HOME and Java_home, respectively. Then I ran 'ant rdv' and 'ant node' - and voilà, I got a CLIENT_CONNECT. After that I launched the JXTA Shell testing if I could grasp the Rdv within the shell.
I configured an EDGE-Node configuration in accordance to the Java-Code (MyPeer.java), setting:

Advanced:
TCP Settings: Enabled = true, Multicast = false, Enable Outg Connections=true,Enable Incom Connnections=false
HTTP Settings:Enabled=true, Enable Outg Connections=true, Enable Incom Connections=false
Rdv/Relays:
Rdv Settings: Use Rdv=true, Use only configured seeds:true, Rdv seeding URIs added: tcp://192.168.230.128:9701 (=seeds.txt of example code)
Rdv Settings: Use Relay=true, Use only configured seeds:true, Relay seeding URIs added: tcp://192.168.230.128:9701 (=seeds.txt of example code)

I started the shell. fired up an 'rdvstatus', but got no connection. Also, 'peers -r' got no result.
The configuration of mine+code can be downloaded at http://maltmann.wi-kassel.de/tmp/JXTA.zip

What did I wrong.

Help would be really appreciated

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
adamman71
Offline
Joined: 2007-01-31
Points: 0

JXTA shell is not maintained anymore...
Jérôme