Skip to main content

Java Preferences using JRE 7u6 Mac OS X

4 replies [Last post]
darkcrawler
Offline
Joined: 2009-02-05
Points: 0

Hi there,

I've been testing my Swing application on mac os x which runs on an applet. Because JDK7u4 does not support Applets, I decided to try the JRE 7u6 Preview.

Following the installation instructions I was able to make the new plugin to work, or at least that's what the Test Java Applet says (http://www.java.com/en/download/testjava.jsp).

The next step was to try my application. I noticed several problems / differences when running JRE 6u31: the popups appear in different positions, the mouse over in the menuItems is not working, etc.

But the problem is that I'm not able to open the Java Console so I can check if there are some exceptions occurring. Initially I thought was because the Java console was hidden, but when I open the Java Preferences (Utilities->Java Preferences) on the mac to check that property, I notice that the advanced tab was not present. Actually none of the tabs is present. The only thing I see is the Java versions I have installed and that's it.

If I remove the JRE7u6 preview and start using the JRE6 everything works fine.

So, am I missing something in the installation process? Is there other Mac users with the same problem?

Thanks in advance,

Luis

P.S.: There is a screenshot attached so you can have a look.

AttachmentSize
screenshot.jpg225.22 KB

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
s_kovatch
Offline
Joined: 2008-10-22
Points: 0

Luis,

When you installed Oracle's 7u6 preview a new Java preference pane was installed into the System Preferences. Open System Preferences and choose the Java icon on the bottom row. The Java Control Panel will open and you can turn on the console via the Advanced tab.

Java Preferences.app is used to control Apple's JDK. When the 7u6 JRE is installed, Java Preferences.app removes the panels not relevant to the Oracle plugin. Expect this application to go away completely in the future -- the newest version of Java installed will be used as the default Java on the command line.

-- Scott K.

darkcrawler
Offline
Joined: 2009-02-05
Points: 0

Hi Scott,

Now I understand. Thanks for the explanation.

Regards,

Luis

anthony_p
Offline
Joined: 2006-07-24
Points: 0

Hi Luis,

I suggest to file bugs for each issues that you're observing (like the popups positioned incorrectly, etc.) You can do that at http://bugs.sun.com/

As to the Java Console and Preferences issue, on the screenshot that you've provided it only lists the 7u4 but not the 7u6. This looks strange. I suggest you to post a question about that on the macosx-port-dev@openjdk.java.net mailing list.

--
best regards,
Anthony

darkcrawler
Offline
Joined: 2009-02-05
Points: 0

Hi Anthony,

Thanks for your reply.

About the popups issue, I need to make my own tests first to see if this is actually a Java bug or a bug in my application.

In the screenshot it only list the 7u4 but not the 7u6 because I only installed the JRE7u6 and not the JDK7u6, since I just need to test the client part. Anyways, today I installed the JDK7u6 and the it did not help since the result is the same.

I already sent an email to the mailing list, but because I did not subscribe before, my post need to be accepted.

As I said before, after I install the JRE7u6 and test it, I get the following:

Your Java configuration is as follows:
Vendor: Oracle Corporation
Version: Java SE 7 Update 06-ea
Operating System: Mac OS X 10.7.4
Architecture: X86_64

So, today I had a close look into the problems and I found something interesting. I tried to run my application from a private deploy in a windows machine but it did not work. I got a 'Error. Click for details'. When clicking, the java console pops out and I noticed the following in the top of the Java console:

Java Plug-in 10.0.2.11
Using JRE version 1.7.0_06-ea-b11 Java HotSpot(TM) 64-Bit Server VM
User home directory = /Users/user

Did you noticed the plug-in version? 10.0.2.11?
It looks like the installation instructions do not work for me... I installed and uninstalled the JRE7u6 several times - like it is in the webpage - and always the same result.

Any clues?!

Luis