Skip to main content

Help: how do I de-install 7u6 early access from my Mac?

2 replies [Last post]
ThomasWolf
Offline
Joined: 2012-07-19
Points: 0

A few weeks ago, I installed an early access version of the Java 7u6 Mac plugin (I think it was b19 or b20). I found a few incompatibilities with an app I use every day and followed the manual steps the web page gave to remove the plugin (basically they involved removing some directories and re-setting symbolic links). They didn't work - after following the steps, java plugins weren't working at all anymore. In my desperation (and because I didn't have the old Mac JDK handy), I re-installed that build.

Today I tried installing a newer build of said plugin (b22) in the hopes that it fixed the incompatibilities I had found earlier, but the installation aborts with the message that I already have a newer plugin installed?!

Can someone point me to a web page that has the plugin removal steps so I can try them again? Perhaps I missed something when I tried previously. Any help is much appreciated.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
sfshaza
Offline
Joined: 2004-06-03
Points: 0

Manually removing a couple files should work. The Mac install pages show you how.

This is the high level page. The links to the JRE and JDK pages show how to uninstall each.
http://docs.oracle.com/javase/7/docs/webnotes/install/index.html#mac (high level page)

As developers, you might also find these pages useful:

http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/packagingApps...
http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/mac-faq.html

Let me know how it goes.

ThomasWolf
Offline
Joined: 2012-07-19
Points: 0

Thanks a bunch. I uninstalled everything and then re-installed 7u6 and it worked.

Now, I have a question regarding compatibility: it appears that 7u6 final is having the same problem the beta had for me: our application doesn't run :-( When the app (WebStart-based) initializes log4j, it throws an UnknownHostException. It never did so in prior releases of the JRE (i.e. 6u33). I see a possible candidate in my Google searches:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7166687
but it's kind of contradictory in its findings: in one place in the evaluation it says that it's a bug, in another it says that it's just a change of behavior in the getHostName() method, implying "Live with it". Well, which is it? All I know for sure is that the app doesn't work now.

I did find a workaround which is kind of strange (and IMO defies the bug description): if I put the FQDN in my /etc/hosts file, the app works, but if I let it be resolved by DHCP (my machine gets its IP via that), it doesn't???

Any advice/suggestion? Would be muchg appreciated.