Skip to main content

Menu issues on Mac OS X 10.9 Mavericks DP 6

6 replies [Last post]
fidodido
Offline
Joined: 2004-09-09
Points: 0

When upgrading to Mavericks DP 6 yesterday, all the menus work improperly, both on 7_u25 and 7_u40

For native menus written in SWT, all the items are disabled (see the 1st attachment)
For swing menus, only have the default application menu and when clicking on the menu, no menu item is shown (see the 2nd attachment)

AttachmentSize
SWT menus.png143.25 KB
Swing menus.png17.67 KB

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
rsiqueira87
Offline
Joined: 2013-08-26
Points: 0

Guys, there is a fix for that!
http://stackoverflow.com/questions/18383381/eclipse-menus-disabled-on-os...

I've installed a package available here: http://support.apple.com/kb/DL1572?viewlocale=en_US&locale=en_US and the problem was fixed!

fidodido
Offline
Joined: 2004-09-09
Points: 0

Thx for the information! I applied the patch and the issue fixed~

rsiqueira87
Offline
Joined: 2013-08-26
Points: 0

Same here (OSX 10.9 - 7_u25), but i think it'll be fixed by apple. It's looks like the issue with skype (on iOS 7 beta). The latest beta fixed the compatibility problem.

fidodido
Offline
Joined: 2004-09-09
Points: 0

One weird thing is, xmind, which is also built on PDE, the menus work well

fidodido
Offline
Joined: 2004-09-09
Points: 0

One walkthrough: add '-Dapple.laf.useScreenMenuBar=false' to startup arguments.

Yet not work for Eclipse

fidodido
Offline
Joined: 2004-09-09
Points: 0

Same issue on 1.6.0_51