Skip to main content

Jdk 8 ARM .

Please note these forums are being decommissioned and use the new and improved forums at
6 replies [Last post]
Joined: 2012-12-24

I download JDK8 from this url : .
After download i unzip into my embedded linux.
Then i set path . After that i run :java -version , but i get No such file or directory . I am sure i run the java command correctly . Pls help . Thanks

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2004-05-05

Please see for tested configurations.

Dalibor Topic
Principal Product Manager
Java Platform Group @ Oracle

Joined: 2013-04-05

Well, it works with the tested configurations however the example (verifying the downloaded version) is a bit misleading because it shows a version from 8.8.2012 (wheezy armel) and not one of the working wheezy raspbians...

Joined: 2013-06-29

Re: jdk 8 ARM

I have loaded this on my RaspberryPi using the instructions here YElement14

It is currently running nereus for theSkyNet projectusing hard float and jdk1.8.0.

For more detail see posts on facebook at Leicester Raspberry Pi User Group.

Joined: 2003-06-16

No success on hp touchpad with ubuntu on webos for jdk8, but jdk7 works.

After understanding( with the help of> ldd java) that there is no link to the
I have created a softlink
/lib/ => /lib/
and it works.
The sad fact is that in this build there is no lambda expressions. They are the reason I was not satisfied with jdk7 which works without problem out of the box.
And as far as I know there is no jdk8 build for ARM with lambda.

Joined: 2013-03-14
Joined: 2004-07-13

Which embedded linux device are you using?
Raspberry pi?

For jdk8, use Raspbian “wheezy” hard-float OS.