Skip to main content

Fail to build openjdk 7 update 6

1 reply [Last post]
bli0406
Offline
Joined: 2013-02-15
Points: 0

I downloaded the archive of openjdk 7 update 6 from this page:

https://jdk7.java.net/source.html

I tried to build it on my mac machine 10.7.5 by following the README-builds.html but failed with lots of errors like "unmappable character for encoding ascii". For example:

../../../src/share/classes/javax/transaction/._TransactionRequiredException.java:1: error: unmappable character for encoding ascii.

This file looks like binary file and I am not sure why it has the prefix "._". Anybody had this issue before? How can I fix it? Thanks!

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
bli0406
Offline
Joined: 2013-02-15
Points: 0

I tried it again on Debian 6, the same error occurred.

The file "._TransactionRequiredException.java" is located in folder "corba/src/share/classes/javax/transaction/".

I can make some progress by skipping the CORBA with BUILD_CORBA=false, the another similar error occurred in C++ file:

/java7/hg/openjdk/hotspot/src/share/vm/compiler/._abstractCompiler.cpp:1:1: error: null character(s) ignored
/java7/hg/openjdk/hotspot/src/share/vm/compiler/._abstractCompiler.cpp:1: error: stray '\5' in program
....

Something must be wrong about these "._" prefixed files.