Skip to main content

Cannot run swingxset.jnlp file

7 replies [Last post]
wizardxxl
Offline
Joined: 2013-04-24
Points: 0

I don't understand but when i try to run swingxset demo i got this error Unable to launch the application

Detail errors:
JNLParseException[ Could not parse launch file. Error at line 0.]
at com.sun.javaws.jnl.XMLFormat.decode(Unknown Source)
at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main.access$000(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

java.io.EOFException: encoding.error.not.xml
at com.sun.deploy.xml.XMLEncoding.decodeXML(Unknown Source)
at com.sun.javaws.jnl.XMLFormat.decode(Unknown Source)
at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)
at com.sun.javaws.Launcher.launch(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main.access$000(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I have tried all google search but still failed to fix this.
Anyboy can help me?
thanks.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Charles22
Offline
Joined: 2013-04-25
Points: 0

Hi wizardxxl, I'm having the same problem, but it is strange because it was working fine last week. I believe that's because a java update.

wizardxxl
Offline
Joined: 2013-04-24
Points: 0

May be Java update causes this error. I tried to uninstall java and install the lastest ones both 32 bits and 64 bits version (my commputer run windows 8 64 bits) but stil get this error.
Does anyboy get the same problem with me?

Charles22
Offline
Joined: 2013-04-25
Points: 0

The problem is that the links are broken right now, "java.net project has been moved over to Kenai infrastructure. As a consequence SwingLabs many (probably all) links are broken - please be patient until they will be fixed as time allows ..."

That explains the (Unknown Source) message in the applet.

kleopatra
Offline
Joined: 2003-06-11
Points: 0

created and issue:

https://java.net/jira/browse/SWINGLABS_DEMOS-83

and applied a tentative fix (changed the codebase in the jnlp) - so the demos should be running again (and are for me). Could you please confirm that it is working for you as well?

Thanks
Jeanette

kleopatra
Offline
Joined: 2003-06-11
Points: 0

Hi Charles,

good to see the someone is reading the project page :-)

Unfortunately ... cough, cough .. that text is years old, never intended to describe the current breakage (as you noted, the webstartables did work before the end of April). Though it might indeed be the reason _again_, kind of re-using by forgetting to update the text.

Waiting for the site admin to comment before trying random changes. Just noticed that java.net project/file access is back to https:// ... (vs. http:// as hard-coded in our jnlp files) - no idea when that happened or whether it might have the observed effect. Or maybe the file access is either blocked or the mapping (from svn --> www) changed?

Cheers
Jeanette

tonya_rae_moore
Offline
Administrator
Joined: 2011-05-20
Points: 0

Moved to SwingLabs forum. Also, try emailing admins@swingx.java.net

kleopatra
Offline
Joined: 2003-06-11
Points: 0

Tonya,

have there been any changes to the site (near the end of April)? Looks like none of our webstartables are working right now, but I'm sure they did before I started my vacation (at about the time of your post :-)

Thanks
Jeanette