Skip to main content

Java 3D Linux performance

6 replies [Last post]
ch3sn3k
Offline
Joined: 2010-12-09
Points: 0

Hello everyone,
I came up with the performance problem. My application (Visualisation of Furuta pendulum) consist one Canvas3D(with SimpleUniverse) placed in JPanel surrounded by Swing components. I’am running this application on touch panel (Intel Atom processor with GMA 945 graphic card). If I run my app under Windows XP, everything works fine. I didn’t measure exact FPS, but it runs smooth.

Here is the problem, for me it would be better to run app under Linux (i.e. Ubuntu), but when I try that. The same app was very very slow. I’ve tried switch between different renderers (-Dj3d.rend=ogl, jogl), but it didn’t help. I don’t know where the problem is, because when I run test app GLXGEARS it runs smooth for OpenGL (around 50-60 FPS) and for Jogl.

My questions are:
Is there any option instead changing renderer (d3d,ogl,jogl), switching off anti-aliasing how to lower hardware requirements?
Can you advise me how to use J3D app with Jogl thought JavaWebstart. (I was forced to copy all jogl libraries directly to the my app jar file to run app with jogl)?
Some idea why myapp works fine under WinXP (ogl and d3d renderer), but not under Linux.?

Thank you for any response.
Ondra

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
itpedersen
Offline
Joined: 2011-02-14
Points: 0

I think that you ubuntu installation dont use hardware 3d rendering because glxgears only running 50-60FPS is VERY SLOW
glxgears runs on my old machine P4 2,4GHZ with somethink like 2700FPS yes you read correct. With a old Gf4200 nvidia.
Be sure that the correct drivers are loaded into ubuntu. Try for instance to run a free 3d game for instance openarena
open a console type: sudo apt-get install openarena
hope this helps

ch3sn3k
Offline
Joined: 2010-12-09
Points: 0

Thank you for your response,
In the meanwhile a did further research and I find out, that problem is maybe in the drivers. My Linux possitive friend tried to do his best and he says that GMA945 drivers arent very well written. So it looks like that problem is combination of Java3D and Swing. (We've played Thux Extreme racer with accetable FPS).

mcneillk
Offline
Joined: 2005-02-03
Points: 0

There is a problem with Ubuntu that can cause slow OpenGL performance, unless you turn off 'Compiz' desktop effects--it's under the Appearence menu.

ch3sn3k
Offline
Joined: 2010-12-09
Points: 0

I have tried that, but it didnt bring any enhancement. :(

mcneillk
Offline
Joined: 2005-02-03
Points: 0

Each configuration will be a litle different, but I have very good results with Java 3D / OpenGL on Ubuntu 10.10 with a GeForce 8400 GS (NVidia hardware drivers 260.19.06).
* On the NVidia X Server Settings, you could try 'dialing down' antialiasing, and force off V Sync--these can have a big impact on performance.
* In Java 3D, you can try with these settings
-Dj3d.implicitAntialiasing=true
-Dj3d.optimizeForSpace=false
-Dsun.java2d.opengl=false
These settings can greatly improve performance, especially the first two... Good luck.

i_zelker
Offline
Joined: 2004-04-15
Points: 0

unsubscribe

On 3/23/2011 12:55 PM, forums@java.net wrote:
> There is a problem with Ubuntu that can cause slow OpenGL performance,
> unless
> you turn off 'Compiz' desktop effects--it's under the Appearence menu.
>
>