Skip to main content

How to get Java3D running with JDK7 on OSX Lion?

Please note these forums are being decommissioned and use the new and improved forums at
No replies
Joined: 2011-04-24


Java 3D 1.5.2 basically worked with JDK6 on OSX (well, sort of - popup menus do not show on 3D areas and other problems). When moving to JDK 1.7, the Java3D libs are not found. My colleague and me tried several things, ending up at an error that some CapabilityChooser is not found.

Are there any instructions how to properly "install" Java3D for JDK 1.7 on OSX?