Skip to main content

Corrupt Images on SLES 11

No replies
kenneykirk
Offline
Joined: 2006-06-05
Points: 0

I have a J2EE app the take multipage tiff images and creates single page tiff images from each page. I do the separation on the server side using the jai plugins for ImageIO. The client makes socket connection and I send each new tiff file as a byte stream. The client only saves the tiff file and does no further processing. When I run the server app on zLinux SUSE Linux 10 server in a WebSphere 7 ND environment it works as expected. It also works in Windows development environment under RAD 8.5 using a WAS 8.5 server. When I run on a zLinux SUSE 11 server in a WAS 8.5 ND environment the first few hundred pages are fine but every page after is just a garble of pixels somewhat in the shape of what was on the page almost like someone took a bucket of water splashed over a freshly printed page. I verified that the problem in not in the transmission of the image to client as I saved copy on the server before transmission but the problem is in the image processing.