Skip to main content

Empty response object

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
No replies
Karsten1976
Offline
Joined: 2011-07-20

When calling a web service on a Oracle Service Bus, my JAX-WS client (JRE 1.6.0_24-b07) receives the following response.

---[HTTP response - http://91.213.134.189:80/Endur/ProxyServices/ReferenceDataCache_PS_v1 - 200]---
Transfer-encoding: chunked
null: HTTP/1.1 200 OK
Content-type: text/xml; charset=utf-8
Proxy-connection: Keep-Alive
Connection: Keep-Alive
X-powered-by: Servlet/2.5 JSP/2.1
Date: Wed, 20 Jul 2011 10:38:00 GMT
<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
<soapenv:Header/>
<S:Body xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
<S:Body>
<EndurDataMessage xmlns="http://www.vattenfall.de/schema/EndurDataService">
<state>SUCCESS</state>
<senderId>1</senderId>
<msgId>aa2a3be4-f167-4e25-9c9e-b45ce4b923e3</msgId>
<date>2011-07-20+02:00</date>
<EndurDataRequest xsi:type="ReferenceDataRequest" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ReferenceDataType>CounterParty</ReferenceDataType>
</EndurDataRequest>
<EndurDataResponse xsi:type="CounterPartyResponse" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<counterParty>
<ID>20162</ID>
<shortName>EDF TRADING LTD_LE</shortName>
<longName>EdF Trading Ltd.</longName>
<internalExternal>External</internalExternal>
<EICCode/>
<partyClass>Legal Entity</partyClass>
<OTCBroker>No</OTCBroker>
</counterParty>
<counterParty>
<ID>23605</ID>
<shortName>CORUS_STAAL_BU</shortName>
<longName>Corus Staal B.V.</longName>
<internalExternal>External</internalExternal>
<EICCode>Kein_BK</EICCode>
<partyClass>Business Unit</partyClass>
<OTCBroker>No</OTCBroker>
</counterParty>
</EndurDataResponse>
</EndurDataMessage>
</S:Body>
</S:Body>
</soapenv:Envelope>--------------------

But the returned object from type EndurDataMessage contains only null and 0 values. Could this be caused by the nested body tags or another error in the SOAP response?