Skip to main content

jtharness having problems loading JUnitSuperTestFinder or JUnitAnnotationTestFinder

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
1 reply [Last post]
mtbrepairman
Offline
Joined: 2013-04-07

Hi,

I am trying to use jtharness to put a front end on my collection of JUnit4 tests.

I've read the section in the JavaTest Harness Architect

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
mtbrepairman
Offline
Joined: 2013-04-07

I tried this:

JUnit 4.x style tests do not use a specific superclass, rather, they tag
classes with the org.junit.Test annotation. The name="ProductName"
content="JavaTest Harness"?> harness library jt-junit.jar provides the
class com.sun.javatest.junit.JUnitAnnotationTestFinder to find 4.x style
tests. It operates much like the JUnitSuperTestFinder class, but looks for
different criteria

... but using JUnitAnnotationTestFinder gave me the same - the testsuite still doesn't load

I've checked that my JUnit4 tests have @Before, @Test, @After tags in the code