Skip to main content

JAI Advanced Imaging libraries not processing TIFF files and get NosuchElementException.

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
1 reply [Last post]
chevulan
Offline
Joined: 2009-04-12

Hi, Lot of articles point to following URL's for JAI Advanced Imaging libraries.

https://jai.dev.java.net/binary-builds.html
https://jai-imageio.dev.java.net/

None of the above URL's seem to exist anymore. What happened to them?

Where are they now?

I somehow was able t download jai_imagio.jar and jai_core.jar and jai_coded.jar. I added them to classpath, jkd library and jre/lib,wed-inf/lib

But I still get

I tried to install the executable, jai-1_1_3-lib-windows-i586-jdk.exe, I got an error message the JDK should be greater than 1.1.3. I am running JDK 1.6 and my JAVA_HOME, JRE_HOME all point to 1.6 JVM.

I am doing this all on my Windows-7 desktop with Websphere 1.6 64-bit JVM.

Does anyone tried using these jar's in 64-bit JVM on Windows-7 specifically IBM Websphere JVM?

I would appreciate your help.

Thanks
Nags

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
chevulan
Offline
Joined: 2009-04-12

All, I finally figured out the problem. The jai_imageio.jar file I had included in my classpath was incorrect. In the sense I built this jai)imagio.jar file using my eclipse environment and I believe the export process did not include META_INF folder and services folder.

So I downloaded older version of jai_imageio.jar file from the URL
http://download.java.net/media/jai-imageio/builds/release/1.1/

This seems to have corrected the NOSuchelement exception.

thanks
Nags