Skip to main content

WSIT, Java, and .NET web services

Please note these forums are being decommissioned and use the new and improved forums at
1 reply [Last post]
Joined: 2012-02-03

I have read for days about people saying that Java can and cannot connect to Microsoft.NET WCF web services. I have tried every combination I can find on the web and it simply does not work.

I have tried wsDualHttpBinding, wsHttpBinding, basicHttpBinding and customBindings.... nothing works. I never have problems consuming the web service using the URL to the WSDL (I am using NetBeans 7.1). The furthest I have gotten in the process is where I make a call in code to a WCF web service method and the program just hangs here (during runtime):

[] parse
INFO: WSP5018: Loaded WSIT configuration from file: file:/C:/Users/Administrator/Documents/NetBeansProjects/BasicProject/build/classes/META-INF/wsit-client.xml.

During project build... I see the following.... and have tried everything (even using customBinding) to get rid of it... with no luck:

parsing WSDL...
[WARNING] SOAP port "wshttp_java": uses a non-standard SOAP 1.2 binding.

I am completely out of ideas. I have read consistently that wshttpbinding should work... because it follows the WS* standards... but so far nothing. I have to believe that by now, the technology has come far enough along to allow interoperability between the two system (given that they are supposed to be using standards).

Any help would be great.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2004-10-01

As for the hang - that suggests problem in communication or processing on service side - I'd recommend to setup some logging on both sides to understand what is going on. Does the endpoint respond to http? What happens when you delete the wsit-client.xml file?

As for the warning - jaxws/metro support soap 1.2 but it's not part of the spec so it's hidden by extension switch - Netbeans sets the switch by default AFAIK, so you can just ignore the warning.