Skip to main content

Using Metro as client for Weblogic Web Services

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
1 reply [Last post]
shiningman
Offline
Joined: 2011-08-16
Points: 0

Hi!

I'm creating a client for some services running in Weblogic.

I've done the client using Netbeans 7 and METRO stack.

The service is running under HTTP with basic authentication and the SOAP messages are signed using the server public key and encrypted using the same key. To achieve this, I only had to configure the keystore with the server certificate and metro already knew how to use it.

I've used Authenticator to send Basic authentication credentials.

Now I'm facing two problems: I'm trying to use a client certificate to sign the messages and still use the server certificate to encrypt the message. I've tried setting the "keyStore" configuration manually in my wsit config file without success.

The second problem is, I can call the web Service operation, but as the message comes with no security, metro throws an exception saying that there was no security on the incoming message.

In the WSDL the security for incoming messages is marked as wsdl:required="false", witch leads me to think that metro should not enforce the use of security in the response.

Using Wireshark I could see the outgoing and incoming messages and its all ok in the response, it comes without security as expected.

Is there a way I can disable the validation of this security?

The WSDL and my Wsit are listed above.

Thank you very much!

Filipe Sousa

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
shiningman
Offline
Joined: 2011-08-16
Points: 0

Hi again. One other thing i've tried was to put the tag referencePolicy only in the request message, but the client still tries to validate the security in the incoming message. I'm also leaving the xml files as attachment, since its not showing.. Thank you again.