Skip to main content

NetBeans 7 & Metro - what am I doing wrong?

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
2 replies [Last post]
yaronn01
Offline
Joined: 2007-12-22

Hi

When I used NetBeans 6.7.1 and Metro 1.4 I was able to create a client for a secured Wcf service (mutual x.509 in message).

I now try to do the same in NetBeans 7 (which ships with Metro 2).

When I run the app I get a null pointer exception with this on the stack trace:

at com.sun.xml.ws.security.impl.policy.CertificateRetriever.digestBST

according to this thread:

http://metro.1045641.n5.nabble.com/Service-Client-fails-with-unusual-message-td1053190.html

I downloaded Metro 2.1. I then used NetBeans to remove the reference to Metro 2 and added reference to Metro 2.1.

Now when I run the application the wsit config is not loaded (I don't get "Loaded WSIT configuration..." in the log).

I use JDK 1.6.

What am I doing wrong?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
yaronn01
Offline
Joined: 2007-12-22

I have actually found it - The idea to add Metro 2.1 was correct. I did not do it correctly though - what I needed to do was to add all jar files of Metro 2.1 one by one.

mishel
Offline
Joined: 2011-06-14

i have the answer